Permalink
Browse files

Make QuickLoader nuking work in 1.9.1

  • Loading branch information...
1 parent 0f23e3e commit 8917a53210f498467c7274a396e8276e904d3585 @lsegal lsegal committed Jun 14, 2011
Showing with 3 additions and 1 deletion.
  1. +3 −1 lib/rubygems.rb
View
@@ -7,7 +7,9 @@
unless gem_disabled
# Nuke the Quickloader stuff
- Gem::QuickLoader.remove if defined?(Gem::QuickLoader)
+ if defined?(Gem::QuickLoader) && Gem::QuickLoader.respond_to?(:remove)
+ Gem::QuickLoader.remove
+ end
end
require 'rubygems/defaults'

0 comments on commit 8917a53

Please sign in to comment.