Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Extensible DSL for automatically tending your Farmville farm.
Ruby
branch: master

Fetching latest commit…

Cannot retrieve the latest commit at this time

Failed to load latest commit information.
bin
lib
scripts
test
wiki
.gitignore
.ruby-version
Rakefile
copyright.txt
farm.yaml
farmer_otto.gemspec
license.txt
readme.md

readme.md

Farmer Otto

Farmer Otto thanks these great projects:

Ruby JRuby Zynga/Farmville

Farmer Otto is a set of tools for automating common tasks in Farmville.

For instance, you might want to craft the items required to fully develop your Wishing Fountain. You'll need 609 drill bits, 293 copper tubes, and 293 cut bamboos. That's a lot of clicking Make It and Get It. For top production, you'll also want to craft on all of your farms. That's a lot of coordinated clicking to move through all the farms, crafting on each one.

Maybe you're crazed and want the :moneybag: 2.4 million coins :moneybag:, coconuts, and jade from Wishing Fountains on all of your twelve farms. That will require 13,340 crafted items.

You can tell Farmer Otto to craft all those items for you with this script:

standard_farm_count.times do
  travel_to_least_recent_farm
  craftshop :open

  # If your craftshop has fewer than 8 stations, the extra
  # get_it clicks will land in neutral space.
  craftshop :get_it, count: 8

  # Make twice as many drill bits since a Wishing Fountain stage
  # requires 15 drill bits, 8 cut bamboos, and 8 copper tubes.
  craftshop :drill_bit,   count: 4
  craftshop :cut_bamboo,  count: 2
  craftshop :copper_tube, count: 2

  craftshop :close
end

Farmer Otto uses the conventions of the Ruby programming language to specify what Otto should do. Some of it might look a little geeky, but there are only a few concepts you need to learn. Check the Wiki for some hints.

Still too hard? Let me know; perhaps we can make it even simpler. If someone else has already written a script for your task, you might not have to learn anything – just run the script. Check the scripts directory or the Scripts page on the Wiki.

prerequisites

  1. Java 5 or later
  2. JRuby 1.7 or later
Something went wrong with that request. Please try again.