Permalink
Browse files

Run tests against rails 3.1, 3.2 and v4.0 with appraisal

Conflicts:
	.gitignore
	Gemfile.lock
	exception_notification.gemspec
  • Loading branch information...
2 parents 4e29795 + f1fc823 commit ad8858d5e3f24ed178e31b1bf28a074310f9ffa8 @jweslley jweslley committed Apr 20, 2013
Showing with 47 additions and 2 deletions.
  1. +1 −0 .gitignore
  2. +5 −0 .travis.yml
  3. +11 −0 Appraisals
  4. +4 −0 Gemfile.lock
  5. +3 −1 Rakefile
  6. +2 −1 exception_notification.gemspec
  7. +7 −0 gemfiles/rails3_1.gemfile
  8. +7 −0 gemfiles/rails3_2.gemfile
  9. +7 −0 gemfiles/rails4_0.gemfile
View
@@ -1 +1,2 @@
/coverage/
+*.gemfile.lock
View
@@ -2,3 +2,8 @@ language: ruby
rvm:
- 1.9.3
- 2.0.0
+gemfile:
+ - Gemfile
+ - gemfiles/rails3_1.gemfile
+ - gemfiles/rails3_2.gemfile
+ - gemfiles/rails4_0.gemfile
View
@@ -0,0 +1,11 @@
+appraise "rails3_1" do
+ gem 'rails', '~> 3.1.0'
+end
+
+appraise "rails3_2" do
+ gem 'rails', '~> 3.2.0'
+end
+
+appraise "rails4_0" do
+ gem 'rails', :git => 'git://github.com/rails/rails.git'
+end
View
@@ -35,6 +35,9 @@ GEM
activesupport (3.2.6)
i18n (~> 0.6)
multi_json (~> 1.0)
+ appraisal (0.5.2)
+ bundler
+ rake
arel (3.0.2)
builder (3.0.0)
colorize (0.5.8)
@@ -133,6 +136,7 @@ PLATFORMS
ruby
DEPENDENCIES
+ appraisal
coveralls (~> 0.6.5)
exception_notification!
httparty (~> 0.10.2)
View
@@ -1,5 +1,7 @@
-require 'bundler'
+require 'rubygems'
+require 'bundler/setup'
Bundler::GemHelper.install_tasks
+require 'appraisal'
require 'rake/testtask'
@@ -14,10 +14,11 @@ Gem::Specification.new do |s|
s.add_dependency("actionmailer", ">= 3.0.4")
s.add_dependency("activesupport", ">= 3.0.4")
+ s.add_development_dependency "rails", ">= 3.0.4"
s.add_development_dependency "tinder", "~> 1.8"
s.add_development_dependency "httparty", "~> 0.10.2"
- s.add_development_dependency "rails", ">= 3.0.4"
s.add_development_dependency "mocha", ">= 0.13.0"
s.add_development_dependency "sqlite3", ">= 1.3.4"
s.add_development_dependency "coveralls", "~> 0.6.5"
+ s.add_development_dependency "appraisal", ">= 0"
end
@@ -0,0 +1,7 @@
+# This file was generated by Appraisal
+
+source "https://rubygems.org"
+
+gem "rails", "~> 3.1.0"
+
+gemspec :path=>"../"
@@ -0,0 +1,7 @@
+# This file was generated by Appraisal
+
+source "https://rubygems.org"
+
+gem "rails", "~> 3.2.0"
+
+gemspec :path=>"../"
@@ -0,0 +1,7 @@
+# This file was generated by Appraisal
+
+source "https://rubygems.org"
+
+gem "rails", :git=>"git://github.com/rails/rails.git"
+
+gemspec :path=>"../"

0 comments on commit ad8858d

Please sign in to comment.