Permalink
Browse files

update to akka-2.0.4, and plugin release to 0.6 (but still wip)

  • Loading branch information...
smartiniOnGitHub committed Nov 22, 2012
1 parent 0b9e95c commit 0e27f0a8cc3964a5e848d6e058bb055248a83892
Showing with 16 additions and 2 deletions.
  1. +1 −1 AkkaGrailsPlugin.groovy
  2. +10 −0 docs/TODO.md
  3. +1 −1 grails-app/conf/BuildConfig.groovy
  4. +4 −0 src/docs/guide/1.1 History.gdoc
View
@@ -18,7 +18,7 @@
// import org.apache.log4j.Logger
class AkkaGrailsPlugin {
- def version = "0.8"
+ def version = "0.6"
def grailsVersion = "2.0 > *"
def dependsOn = [:]
def pluginExcludes = [
View
@@ -4,6 +4,12 @@ grails-akka - TODO
TODO
----
+- for release 0.6 (second public release):
+ + publish the plugin,
+ + update generated gdocs on github-pages ...
+ + then set version to 0.7 (or 0.8) for the next release ...
+
+
- for release 1.0:
+ verify the info put in readme.md
* and then, create another test webapp (but not inline here) where to install it, following only readme info, to ensure they are right ...
@@ -24,6 +30,7 @@ http://doc.akka.io/docs/akka/2.0.3/java/futures.html
- for release 1.0 or later:
+ + update dependencies to Akka-2.1.x and Scala-2.10.x ...
+ use some remote actor ...
* grails-akka-test webapp integration tests:
call some remote actors (before start its server, maybe with a microkernel application under integration tests, as this) ...
@@ -37,6 +44,7 @@ http://doc.akka.io/docs/akka/2.0.3/java/typed-actors.html
- others:
+ + update dependencies to Java 7 ...
+ enabling scala ...
* re-enable the creation of scala source folders when installing the plugin in a test webapp ...
* enable scala compilation and verify if some scala content there is compiled ...
@@ -93,6 +101,8 @@ cls && grails test-app integration: -echoOut
* ensure LICENSE file is put in root of the generated plugin ... ok
* add by hand README.md, NOTICE, and RELEASE-NOTES and README if present ... ok
+- for release 0.6 (second public release):
+ + update akka to 2.0.4 ... ok
---------------
@@ -26,7 +26,7 @@ grails.project.target.level = 1.6
// grails.project.work.dir = 'target'
-def akkaVersion = '2.0.3'
+def akkaVersion = '2.0.4'
grails.project.dependency.resolution = {
// inherit Grails' default dependencies
@@ -1,5 +1,9 @@
h4. History
+* November 2012
+** 0.6 release
+*** Updated Akka to 2.0.4
+
* September 2012
** 0.5 release
*** First public version of the plugin, with some basic features

0 comments on commit 0e27f0a

Please sign in to comment.