Skip to content
Go to file

Latest commit

* Run tests for PHP5.x
* Start from 5.3 since composer requires it and without it we cannot install phpunit
* Specify dist for 5.3
* Disabled nightly testing because phpunit doesn't support php8 yet.

Git stats


Failed to load latest commit information.
Latest commit message
Commit time
Oct 9, 2018

Smarty 3 template engine

Build Status


For documentation see


Smarty can be run with PHP 5.2 to PHP 7.4.

Distribution repository

Smarty 3.1.28 introduces run time template inheritance

Read the NEW_FEATURES and INHERITANCE_RELEASE_NOTES file for recent extensions to Smarty 3.1 functionality

Smarty versions 3.1.11 or later are now on github and can be installed with Composer.

The "smarty/smarty" package will start at libs/.... subfolder.

To get the latest stable version of Smarty 3.1 use:

"require": {
    "smarty/smarty": "~3.1"

in your composer.json file.

To get the trunk version use:

"require": {
    "smarty/smarty": "~3.1@dev"

For a specific version use something like:

"require": {
    "smarty/smarty": "3.1.19"

PHPUnit test can be installed by corresponding composer entries like:

"require": {
    "smarty/smarty-phpunit": "3.1.19"

Similar applies for the lexer/parser generator.

"require": {
    "smarty/smarty-lexer": "3.1.19"

Or you could use:

"require": {
    "smarty/smarty-dev": "3.1.19"

Which is a wrapper to install all 3 packages.

Composer can also be used for Smarty2 versions 2.6.24 to 2.6.30.

You can’t perform that action at this time.