About this update

OpenSesame 3.2.5 Kafkaesque Koffka is the fifth maintenance release in the 3.2 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.2 series.

Notable improvements:

  • A new Japanese translation by Yuya Kinzuka (@aldichollow)
  • A revised Spanish translation by Roberto de Cecilio
  • Canvas.show() emits a warning when flipping took more than 16 ms
  • Canvas.elements_at() now uses proper geometry to check the borders of elements
  • A new standards-compliant logging system
  • Reduced start-up time by deferred loading of Jupyter Console

If you are upgrading from OpenSesame 3.1 or earlier, please see the list of important changes:

Credits

Thanks to:

  • Daniel Schreij (@dschreij) for his work on the Mac OS package
  • Yuya Kinzuka (@aldichollow) for contributing a Japanese translation
  • Roberto De Cecilio for revising the Spanish translation

Bug fixes and improvements

opensesame:

  • Updated to 3.2.5
  • Issue #634: Canvas drawing order not preserved in legacy backend (Bug)
  • Issue #631: Canvas elements should better detect whether a point falls inside them (Enhancement)
  • Issue #621: Rating scale does not react in form_base plugin for Expyriment backend (Unverified)
  • Issue #628: Mouse positions and responses not flushed when using psychopy as a backend (Bug)
  • Issue #633: Flushing keyboard and mouse events doesn't work on Ubuntu (and maybe Mac OS) (Bug)
  • Issue #618: Windows installer creates wrong command path in registry
  • Issue #627: Allow searching for multiple variables in variable inspector (Enhancement)
  • Issue #632: Logger chokes on nan values (Bug)
  • Issue #630: Frame keyword of Image and ImageButton widget is broken (Bug)
  • Issue #629: safe_decode() is not completely safe (Bug)
  • Issue #626: Automatically hide (some) notifications on mouse over (Enhancement)
  • Issue #623: Starting takes a long time on some systems (Enhancement)
  • Issue #607: opensesamerun.exe is not working (Bug)

python-datamatrix:

  • Updated to 0.9.4

python-qnotifications:

  • Updated to 2.0.1

Packages

Windows Python 2.7

name: opensesame_3.2.5a9-py2.7-win32-1
channels:
- cogsci
- conda-forge
- defaults
dependencies:
- anaconda-client=1.6.3=py27_0
- backports=1.0=py27_0
- backports_abc=0.5=py27_0
- bleach=1.5.0=py27_0
- bzip2=1.0.6=vc9_3
- certifi=2016.2.28=py27_0
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.1.2=py_0
- qscintilla2=2.9.3=py27_vc9_0
- requests-oauthlib=0.6.2=py_0
- webcolors=1.5=py27_0
- colorama=0.3.9=py27_0
- configparser=3.5.0=py27_0
- decorator=4.1.2=py27_0
- entrypoints=0.2.3=py27_0
- enum34=1.1.6=py27_0
- freetype=2.5.5=vc9_2
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- html5lib=0.999=py27_0
- icu=57.1=vc9_0
- ipykernel=4.6.1=py27_0
- ipython=5.3.0=py27_0
- ipython_genutils=0.2.0=py27_0
- ipywidgets=6.0.0=py27_0
- jinja2=2.9.6=py27_0
- jpeg=9b=vc9_0
- jsonschema=2.6.0=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=5.1.0=py27_0
- jupyter_console=5.2.0=py27_0
- jupyter_core=4.3.0=py27_0
- libpng=1.6.30=vc9_1
- libtiff=4.0.6=vc9_3
- markdown=2.6.9=py27_0
- markupsafe=1.0=py27_0
- mistune=0.7.4=py27_0
- mkl=2017.0.3=0
- nbconvert=5.2.1=py27_0
- nbformat=4.4.0=py27_0
- notebook=5.0.0=py27_0
- numpy=1.13.1=py27_0
- olefile=0.44=py27_0
- openssl=1.0.2l=vc9_0
- pandocfilters=1.4.2=py27_0
- path.py=10.3.1=py27_0
- pathlib2=2.3.0=py27_0
- pickleshare=0.7.4=py27_0
- pillow=4.2.1=py27_0
- pip=9.0.1=py27_1
- prompt_toolkit=1.0.15=py27_0
- pyflakes=1.6.0=py27_0
- pygments=2.2.0=py27_0
- pyopengl=3.1.1a1=np113py27_0
- pyopengl-accelerate=3.1.1a1=np113py27_0
- pyqt=5.6.0=py27_2
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.13=1
- python-dateutil=2.6.1=py27_0
- pytz=2017.2=py27_0
- pyyaml=3.12=py27_0
- pyzmq=16.0.2=py27_0
- qt=5.6.2=vc9_6
- qtawesome=0.4.4=py27_0
- qtconsole=4.3.1=py27_0
- qtpy=1.3.1=py27_0
- requests=2.14.2=py27_0
- scandir=1.5=py27_0
- scipy=0.19.1=np113py27_0
- setuptools=36.4.0=py27_1
- shapely=1.6.2=py27_0 # Added in 3.2.5
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.18=py27_0
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.5.0.1=py27_0
- testpath=0.3.1=py27_0
- tornado=4.5.2=py27_0
- traitlets=4.3.2=py27_0
- vc=9=0
- vs2008_runtime=9.00.30729.5054=0
- wcwidth=0.1.7=py27_0
- wheel=0.29.0=py27_0
- widgetsnbextension=3.0.2=py27_0
- win_unicode_console=0.5=py27_0
- wincertstore=0.2=py27_0
- yaml=0.1.6=0
- zlib=1.2.11=vc9_0
- ffmpeg=3.4.1
- pip:
  - arrow==0.7.0
  - backports-abc==0.5
  - backports.shutil-get-terminal-size==1.0.0
  - backports.ssl-match-hostname==3.5.0.1
  - cffi==1.11.2
  - configobj==5.0.6
  - et-xmlfile==1.0.1
  - http://files.cogsci.nl/software/opensesame/pre-releases/expyriment-0.9.1b2_11_gc100ee8-py2-none-any.whl
  - fastnumbers==2.0.2
  - future==0.16.0
  - humanize==0.5.1
  - imageio==2.2.0
  - ipython-genutils==0.2.0
  - jdcal==1.3
  - json-tricks==3.11.0
  - jupyter-client==5.1.0
  - jupyter-console==5.2.0
  - jupyter-core==4.3.0
  - mediadecoder==0.1.5
  - moviepy==0.2.3.2
  - oauthlib==1.1.2
  - openpyxl==2.4.9
  - opensesame-extension-osf==1.1.1
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-plugin-psychopy==0.5.0
  - opensesame-windows-launcher==0.4.2 # Updated in 3.2.2
  - prettytable==0.7.2
  - prompt-toolkit==1.0.15
  - psychopy==1.85.3
  - pyaudio==0.2.11
  - pycparser==2.18
  - pygame==1.9.3
  - pyglet==1.3.0
  - python-bidi==0.4.0
  - python-datamatrix==0.9.4 # Updated in 3.2.5
  - python-fileinspector==1.0.2
  - python-opensesame==3.2.5a9 # Updated in 3.2.5
  - python-pseudorandom==0.2.2
  - python-pygaze==0.6.0a25 # Updated in 3.2.2
  - python-qdatamatrix==0.1.18
  - python_qnotifications==2.0.1 # Updated in 3.2.5
  - python-qosf==1.2.3 # Updated in 3.2.3
  - python-qprogedit==4.0.11
  - python-qtpip==0.1.5
  - requests-oauthlib==0.6.2
  - sounddevice==0.3.9
  - tqdm==4.19.5
  - webcolors==1.5
  - win-unicode-console==0.5
  - yolk3k==0.9

3.2.2 Kafkaesque Koffka (2nd maintenance release)

@smathot smathot released this Mar 23, 2018 · 93 commits to koffka since this release

About this update

OpenSesame 3.2.2 Kafkaesque Koffka is the second maintenance release in the 3.2 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.2 series.

If you are upgrading from OpenSesame 3.1 or earlier, please see the list of important changes:

Credits

Thanks to:

Bug fixes and improvements

opensesame:

datamatrix:

  • Updated to 0.8.3

pygaze:

  • Updated to 0.6.0a25

Packages

Windows Python 2.7

name: opensesame_3.2.2-py2.7-win32-1
channels:
- cogsci
- conda-forge
- defaults
dependencies:
- anaconda-client=1.6.3=py27_0
- backports=1.0=py27_0
- backports_abc=0.5=py27_0
- bleach=1.5.0=py27_0
- bzip2=1.0.6=vc9_3
- certifi=2016.2.28=py27_0
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.1.2=py_0
- qscintilla2=2.9.3=py27_vc9_0
- requests-oauthlib=0.6.2=py_0
- webcolors=1.5=py27_0
- colorama=0.3.9=py27_0
- configparser=3.5.0=py27_0
- decorator=4.1.2=py27_0
- entrypoints=0.2.3=py27_0
- enum34=1.1.6=py27_0
- freetype=2.5.5=vc9_2
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- html5lib=0.999=py27_0
- icu=57.1=vc9_0
- ipykernel=4.6.1=py27_0
- ipython=5.3.0=py27_0
- ipython_genutils=0.2.0=py27_0
- ipywidgets=6.0.0=py27_0
- jinja2=2.9.6=py27_0
- jpeg=9b=vc9_0
- jsonschema=2.6.0=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=5.1.0=py27_0
- jupyter_console=5.2.0=py27_0
- jupyter_core=4.3.0=py27_0
- libpng=1.6.30=vc9_1
- libtiff=4.0.6=vc9_3
- markdown=2.6.9=py27_0
- markupsafe=1.0=py27_0
- mistune=0.7.4=py27_0
- mkl=2017.0.3=0
- nbconvert=5.2.1=py27_0
- nbformat=4.4.0=py27_0
- notebook=5.0.0=py27_0
- numpy=1.13.1=py27_0
- olefile=0.44=py27_0
- openssl=1.0.2l=vc9_0
- pandocfilters=1.4.2=py27_0
- path.py=10.3.1=py27_0
- pathlib2=2.3.0=py27_0
- pickleshare=0.7.4=py27_0
- pillow=4.2.1=py27_0
- pip=9.0.1=py27_1
- prompt_toolkit=1.0.15=py27_0
- pyflakes=1.6.0=py27_0
- pygments=2.2.0=py27_0
- pyopengl=3.1.1a1=np113py27_0
- pyopengl-accelerate=3.1.1a1=np113py27_0
- pyqt=5.6.0=py27_2
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.13=1
- python-dateutil=2.6.1=py27_0
- pytz=2017.2=py27_0
- pyyaml=3.12=py27_0
- pyzmq=16.0.2=py27_0
- qt=5.6.2=vc9_6
- qtawesome=0.4.4=py27_0
- qtconsole=4.3.1=py27_0
- qtpy=1.3.1=py27_0
- requests=2.14.2=py27_0
- scandir=1.5=py27_0
- scipy=0.19.1=np113py27_0
- setuptools=36.4.0=py27_1
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.18=py27_0
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.5.0.1=py27_0
- testpath=0.3.1=py27_0
- tornado=4.5.2=py27_0
- traitlets=4.3.2=py27_0
- vc=9=0
- vs2008_runtime=9.00.30729.5054=0
- wcwidth=0.1.7=py27_0
- wheel=0.29.0=py27_0
- widgetsnbextension=3.0.2=py27_0
- win_unicode_console=0.5=py27_0
- wincertstore=0.2=py27_0
- yaml=0.1.6=0
- zlib=1.2.11=vc9_0
- ffmpeg=3.4.1
- pip:
  - arrow==0.7.0
  - backports-abc==0.5
  - backports.shutil-get-terminal-size==1.0.0
  - backports.ssl-match-hostname==3.5.0.1
  - cffi==1.11.2
  - configobj==5.0.6
  - et-xmlfile==1.0.1
  - http://files.cogsci.nl/software/opensesame/pre-releases/expyriment-0.9.1b2_11_gc100ee8-py2-none-any.whl
  - fastnumbers==2.0.2
  - future==0.16.0
  - humanize==0.5.1
  - imageio==2.2.0
  - ipython-genutils==0.2.0
  - jdcal==1.3
  - json-tricks==3.11.0
  - jupyter-client==5.1.0
  - jupyter-console==5.2.0
  - jupyter-core==4.3.0
  - mediadecoder==0.1.5
  - moviepy==0.2.3.2
  - oauthlib==1.1.2
  - openpyxl==2.4.9
  - opensesame-extension-osf==1.1.1
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-plugin-psychopy==0.5.0
  - opensesame-windows-launcher==0.4.2 # Updated in 3.2.2
  - prettytable==0.7.2
  - prompt-toolkit==1.0.15
  - psychopy==1.85.3
  - pyaudio==0.2.11
  - pycparser==2.18
  - pygame==1.9.3
  - pyglet==1.3.0
  - python-bidi==0.4.0
  - python-datamatrix==0.8.3 # Updated in 3.2.2
  - python-fileinspector==1.0.2
  - python-opensesame==3.2.2 # Updated in 3.2.2
  - python-pseudorandom==0.2.2
  - python-pygaze==0.6.0a25 # Updated in 3.2.2
  - python-qdatamatrix==0.1.18
  - python-qnotifications==1.1.1
  - python-qosf==1.2.2
  - python-qprogedit==4.0.11
  - python-qtpip==0.1.5
  - requests-oauthlib==0.6.2
  - sounddevice==0.3.9
  - tqdm==4.19.5
  - webcolors==1.5
  - win-unicode-console==0.5
  - yolk3k==0.9

Windows Python 3.6

name: opensesame_3.2.2-py3.6-win64-1
channels:
- conda-forge
- cogsci
- defaults
dependencies:
- anaconda-client=1.6.5=py_0
- asn1crypto=0.22.0=py36_0
- bleach=2.0.0=py36_0
- ca-certificates=2017.11.5=0
- certifi=2017.11.5=py36_0
- cffi=1.11.2=py36_0
- chardet=3.0.4=py36_0
- clyent=1.2.2=py36_0
- colorama=0.3.9=py36_0
- cryptography=2.1.4=py36_0
- decorator=4.1.2=py36_0
- entrypoints=0.2.3=py36_1
- freetype=2.8.1=vc14_0
- html5lib=1.0.1=py_0
- icu=58.2=vc14_0
- idna=2.6=py36_1
- ipykernel=4.7.0=py36_0
- ipython=6.2.1=py36_1
- ipython_genutils=0.2.0=py36_0
- ipywidgets=7.1.0=py36_0
- jedi=0.10.2=py36_0
- jinja2=2.10=py36_0
- jpeg=9b=vc14_2
- jsonschema=2.5.1=py36_0
- jupyter=1.0.0=py36_0
- jupyter_client=5.2.1=py36_0
- jupyter_console=5.2.0=py36_0
- jupyter_core=4.4.0=py_0
- libpng=1.6.34=vc14_0
- libtiff=4.0.9=vc14_0
- markdown=2.6.9=py36_0
- markupsafe=1.0=py36_0
- mistune=0.8.3=py_0
- nbconvert=5.3.1=py_1
- nbformat=4.4.0=py36_0
- notebook=5.2.2=py36_1
- olefile=0.44=py36_0
- openssl=1.0.2n=vc14_0
- pandoc=2.1=0
- pandocfilters=1.4.1=py36_0
- pickleshare=0.7.4=py36_0
- pillow=5.0.0=py36_0
- pip=9.0.1=py36_1
- prompt_toolkit=1.0.15=py36_0
- pycparser=2.18=py36_0
- pygments=2.2.0=py36_0
- pyopengl=3.1.1a1=py36_0
- pyopenssl=17.2.0=py36_0
- pyqt=5.6.0=py36_4
- pyserial=3.4=py36_0
- pysocks=1.6.8=py36_1
- python=3.6.4=0
- python-dateutil=2.6.1=py36_0
- pytz=2017.3=py_2
- pyyaml=3.12=py36_1
- pyzmq=16.0.2=py36_3
- qscintilla2=2.9.3=py36_2
- qt=5.6.2=vc14_1
- qtconsole=4.3.1=py36_0
- qtpy=1.3.1=py36_0
- requests=2.18.4=py36_1
- setuptools=38.4.0=py36_0
- simplegeneric=0.8.1=py36_0
- sip=4.18=py36_1
- six=1.11.0=py36_1
- sqlite=3.20.1=vc14_2
- testpath=0.3.1=py36_0
- tornado=4.5.3=py36_0
- traitlets=4.3.2=py36_0
- urllib3=1.22=py36_0
- vc=14=0
- vs2015_runtime=14.0.25420=0
- wcwidth=0.1.7=py36_0
- webencodings=0.5=py36_0
- wheel=0.30.0=py36_2
- widgetsnbextension=3.1.0=py36_0
- win_inet_pton=1.0.1=py36_1
- wincertstore=0.2=py36_0
- yaml=0.1.7=vc14_0
- zlib=1.2.11=vc14_0
- mkl=2017.0.3=0
- numpy=1.13.1=py36_0
- pyopengl-accelerate=3.1.1a1=np113py36_0
- scipy=0.19.1=np113py36_0
- pip:
  - arrow==0.12.0
  - et-xmlfile==1.0.1
  - expyriment==0.9.0
  - fastnumbers==2.0.2
  - future==0.16.0
  - humanize==0.5.1
  - imageio==2.1.2
  - ipython-genutils==0.2.0
  - jdcal==1.3
  - jupyter-client==5.2.1
  - jupyter-console==5.2.0
  - jupyter-core==4.4.0
  - mediadecoder==0.1.5
  - moviepy==0.2.3.2
  - oauthlib==2.0.6
  - openpyxl==2.4.9
  - opensesame-extension-osf==1.1.1
  - opensesame-plugin-media-player-mpy==0.1.6
  - prettytable==0.7.2
  - prompt-toolkit==1.0.15
  - pyaudio==0.2.11
  - pygame==1.9.3
  - pyparallel==0.2.2
  - python-bidi==0.4.0
  - python-datamatrix==0.8.3 # Updated in 3.2.2
  - python-fileinspector==1.0.2
  - python-opensesame==3.2.2 # Updated in 3.2.2
  - python-pseudorandom==0.2.2
  - python-qdatamatrix==0.1.18 # Updated in 3.2.2
  - python-qnotifications==1.1.1
  - python-qosf==1.2.2
  - python-qprogedit==4.0.11
  - python-qtpip==0.1.5
  - qtawesome==0.4.4
  - requests-oauthlib==0.8.0
  - sounddevice==0.3.10
  - tqdm==4.11.2
  - webcolors==1.7
  - win-inet-pton==1.0.1
  - yolk3k==0.9

3.2.1 Kafkaesque Koffka (1st maintenance release)

@smathot smathot released this Feb 15, 2018 · 133 commits to koffka since this release

About this update

OpenSesame 3.2.1 Kafkaesque Koffka is the first maintenance release in the 3.2 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.2 series.

The main reason for this quick maintenance release is an issue with variable properties of text elements in sketchpad items.

If you are upgrading from OpenSesame 3.1 or earlier, please see the list of important changes:

Bug fixes and improvements

opensesame:

datamatrix:

  • Updated to 0.8.1

Packages

Windows Python 2.7

name: opensesame_3.2.1-py2.7-win32-1
channels:
- cogsci
- conda-forge
- defaults
dependencies:
- anaconda-client=1.6.3=py27_0
- backports=1.0=py27_0
- backports_abc=0.5=py27_0
- bleach=1.5.0=py27_0
- bzip2=1.0.6=vc9_3
- certifi=2016.2.28=py27_0
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.1.2=py_0
- qscintilla2=2.9.3=py27_vc9_0
- requests-oauthlib=0.6.2=py_0
- webcolors=1.5=py27_0
- colorama=0.3.9=py27_0
- configparser=3.5.0=py27_0
- decorator=4.1.2=py27_0
- entrypoints=0.2.3=py27_0
- enum34=1.1.6=py27_0
- freetype=2.5.5=vc9_2
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- html5lib=0.999=py27_0
- icu=57.1=vc9_0
- ipykernel=4.6.1=py27_0
- ipython=5.3.0=py27_0
- ipython_genutils=0.2.0=py27_0
- ipywidgets=6.0.0=py27_0
- jinja2=2.9.6=py27_0
- jpeg=9b=vc9_0
- jsonschema=2.6.0=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=5.1.0=py27_0
- jupyter_console=5.2.0=py27_0
- jupyter_core=4.3.0=py27_0
- libpng=1.6.30=vc9_1
- libtiff=4.0.6=vc9_3
- markdown=2.6.9=py27_0
- markupsafe=1.0=py27_0
- mistune=0.7.4=py27_0
- mkl=2017.0.3=0
- nbconvert=5.2.1=py27_0
- nbformat=4.4.0=py27_0
- notebook=5.0.0=py27_0
- numpy=1.13.1=py27_0
- olefile=0.44=py27_0
- openssl=1.0.2l=vc9_0
- pandocfilters=1.4.2=py27_0
- path.py=10.3.1=py27_0
- pathlib2=2.3.0=py27_0
- pickleshare=0.7.4=py27_0
- pillow=4.2.1=py27_0
- pip=9.0.1=py27_1
- prompt_toolkit=1.0.15=py27_0
- pyflakes=1.6.0=py27_0
- pygments=2.2.0=py27_0
- pyopengl=3.1.1a1=np113py27_0
- pyopengl-accelerate=3.1.1a1=np113py27_0
- pyqt=5.6.0=py27_2
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.13=1
- python-dateutil=2.6.1=py27_0
- pytz=2017.2=py27_0
- pyyaml=3.12=py27_0
- pyzmq=16.0.2=py27_0
- qt=5.6.2=vc9_6
- qtawesome=0.4.4=py27_0
- qtconsole=4.3.1=py27_0
- qtpy=1.3.1=py27_0
- requests=2.14.2=py27_0
- scandir=1.5=py27_0
- scipy=0.19.1=np113py27_0
- setuptools=36.4.0=py27_1
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.18=py27_0
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.5.0.1=py27_0
- testpath=0.3.1=py27_0
- tornado=4.5.2=py27_0
- traitlets=4.3.2=py27_0
- vc=9=0
- vs2008_runtime=9.00.30729.5054=0
- wcwidth=0.1.7=py27_0
- wheel=0.29.0=py27_0
- widgetsnbextension=3.0.2=py27_0
- win_unicode_console=0.5=py27_0
- wincertstore=0.2=py27_0
- yaml=0.1.6=0
- zlib=1.2.11=vc9_0
- ffmpeg=3.4.1
- pip:
  - arrow==0.7.0
  - backports-abc==0.5
  - backports.shutil-get-terminal-size==1.0.0
  - backports.ssl-match-hostname==3.5.0.1
  - cffi==1.11.2
  - configobj==5.0.6
  - et-xmlfile==1.0.1
  - expyriment==0.9.0
  - fastnumbers==2.0.2
  - future==0.16.0
  - humanize==0.5.1
  - imageio==2.2.0
  - ipython-genutils==0.2.0
  - jdcal==1.3
  - json-tricks==3.11.0
  - jupyter-client==5.1.0
  - jupyter-console==5.2.0
  - jupyter-core==4.3.0
  - mediadecoder==0.1.5
  - moviepy==0.2.3.2
  - oauthlib==1.1.2
  - openpyxl==2.4.9
  - opensesame-extension-osf==1.1.1
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-plugin-psychopy==0.5.0
  - opensesame-windows-launcher==0.4.1
  - prettytable==0.7.2
  - prompt-toolkit==1.0.15
  - psychopy==1.85.3
  - pyaudio==0.2.11
  - pycparser==2.18
  - pygame==1.9.3
  - pyglet==1.3.0
  - python-bidi==0.4.0
  - python-datamatrix==0.8.1 # Updated in 3.2.1
  - python-fileinspector==1.0.2
  - python-opensesame==3.2.1 # Updated in 3.2.1
  - python-pseudorandom==0.2.2
  - python-pygaze==0.6.0a23
  - python-qdatamatrix==0.1.18
  - python-qnotifications==1.1.1
  - python-qosf==1.2.2
  - python-qprogedit==4.0.11
  - python-qtpip==0.1.5
  - requests-oauthlib==0.6.2
  - sounddevice==0.3.9
  - tqdm==4.19.5
  - webcolors==1.5
  - win-unicode-console==0.5
  - yolk3k==0.9

Windows Python 3.6

name: opensesame_3.2.1-py3.6-win64-1
channels:
- conda-forge
- cogsci
- defaults
dependencies:
- anaconda-client=1.6.5=py_0
- asn1crypto=0.22.0=py36_0
- bleach=2.0.0=py36_0
- ca-certificates=2017.11.5=0
- certifi=2017.11.5=py36_0
- cffi=1.11.2=py36_0
- chardet=3.0.4=py36_0
- clyent=1.2.2=py36_0
- colorama=0.3.9=py36_0
- cryptography=2.1.4=py36_0
- decorator=4.1.2=py36_0
- entrypoints=0.2.3=py36_1
- freetype=2.8.1=vc14_0
- html5lib=1.0.1=py_0
- icu=58.2=vc14_0
- idna=2.6=py36_1
- ipykernel=4.7.0=py36_0
- ipython=6.2.1=py36_1
- ipython_genutils=0.2.0=py36_0
- ipywidgets=7.1.0=py36_0
- jedi=0.10.2=py36_0
- jinja2=2.10=py36_0
- jpeg=9b=vc14_2
- jsonschema=2.5.1=py36_0
- jupyter=1.0.0=py36_0
- jupyter_client=5.2.1=py36_0
- jupyter_console=5.2.0=py36_0
- jupyter_core=4.4.0=py_0
- libpng=1.6.34=vc14_0
- libtiff=4.0.9=vc14_0
- markdown=2.6.9=py36_0
- markupsafe=1.0=py36_0
- mistune=0.8.3=py_0
- nbconvert=5.3.1=py_1
- nbformat=4.4.0=py36_0
- notebook=5.2.2=py36_1
- olefile=0.44=py36_0
- openssl=1.0.2n=vc14_0
- pandoc=2.1=0
- pandocfilters=1.4.1=py36_0
- pickleshare=0.7.4=py36_0
- pillow=5.0.0=py36_0
- pip=9.0.1=py36_1
- prompt_toolkit=1.0.15=py36_0
- pycparser=2.18=py36_0
- pygments=2.2.0=py36_0
- pyopengl=3.1.1a1=py36_0
- pyopenssl=17.2.0=py36_0
- pyqt=5.6.0=py36_4
- pyserial=3.4=py36_0
- pysocks=1.6.8=py36_1
- python=3.6.4=0
- python-dateutil=2.6.1=py36_0
- pytz=2017.3=py_2
- pyyaml=3.12=py36_1
- pyzmq=16.0.2=py36_3
- qscintilla2=2.9.3=py36_2
- qt=5.6.2=vc14_1
- qtconsole=4.3.1=py36_0
- qtpy=1.3.1=py36_0
- requests=2.18.4=py36_1
- setuptools=38.4.0=py36_0
- simplegeneric=0.8.1=py36_0
- sip=4.18=py36_1
- six=1.11.0=py36_1
- sqlite=3.20.1=vc14_2
- testpath=0.3.1=py36_0
- tornado=4.5.3=py36_0
- traitlets=4.3.2=py36_0
- urllib3=1.22=py36_0
- vc=14=0
- vs2015_runtime=14.0.25420=0
- wcwidth=0.1.7=py36_0
- webencodings=0.5=py36_0
- wheel=0.30.0=py36_2
- widgetsnbextension=3.1.0=py36_0
- win_inet_pton=1.0.1=py36_1
- wincertstore=0.2=py36_0
- yaml=0.1.7=vc14_0
- zlib=1.2.11=vc14_0
- mkl=2017.0.3=0
- numpy=1.13.1=py36_0
- pyopengl-accelerate=3.1.1a1=np113py36_0
- scipy=0.19.1=np113py36_0
- pip:
  - arrow==0.12.0
  - et-xmlfile==1.0.1
  - expyriment==0.9.0
  - fastnumbers==2.0.2
  - future==0.16.0
  - humanize==0.5.1
  - imageio==2.1.2
  - ipython-genutils==0.2.0
  - jdcal==1.3
  - jupyter-client==5.2.1
  - jupyter-console==5.2.0
  - jupyter-core==4.4.0
  - mediadecoder==0.1.5
  - moviepy==0.2.3.2
  - oauthlib==2.0.6
  - openpyxl==2.4.9
  - opensesame-extension-osf==1.1.1
  - opensesame-plugin-media-player-mpy==0.1.6
  - prettytable==0.7.2
  - prompt-toolkit==1.0.15
  - pyaudio==0.2.11
  - pygame==1.9.3
  - pyparallel==0.2.2
  - python-bidi==0.4.0
  - python-datamatrix==0.8.1 # Updated in 3.2.1
  - python-fileinspector==1.0.2
  - python-opensesame==3.2.1 # Updated in 3.2.1
  - python-pseudorandom==0.2.2
  - python-qdatamatrix==0.1.17
  - python-qnotifications==1.1.1
  - python-qosf==1.2.2
  - python-qprogedit==4.0.11
  - python-qtpip==0.1.5
  - qtawesome==0.4.4
  - requests-oauthlib==0.8.0
  - sounddevice==0.3.10
  - tqdm==4.11.2
  - webcolors==1.7
  - win-inet-pton==1.0.1
  - yolk3k==0.9

3.2.0 Kafkaesque Koffka

@smathot smathot released this Feb 8, 2018 · 0 commits to master since this release

OpenSesame 3.2.0 Kafkaesque Koffka is a major new release with many new features and improvements. A detailed changelog is therefore not available; however, a list of most important changes can be found here:

About this update

OpenSesame 3.1.9 Jazzy James is the ninth maintenance release in the 3.1 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.1 series.

An interesting feature of this release is the inclusion of QtPip, a graphical package manager for PyPi (pip install). This package is a tech preview, and should be used with caution.

If you are upgrading from OpenSesame 3.0 or earlier, please see the list of important changes:

http://osdoc.cogsci.nl/3.1/important-changes-3

Credits

Thanks to:

Jarik den Hartog (@JdenHartog) for his code contributions
Daniel Schreij (@dschreij) for his work on the Mac OS package

Bug fixes and improvements

opensesame:

  • Updated to 3.1.9
  • Issue #553: Set audiosystem_autostart to False for Expyriment (Bug)
  • Fix an issue with sorting the loop table after generating a full-factorial design

qtpip:

  • Newly added 0.1.5 as tech preview

Packages (Windows Python 2.7 package)

Detailed package information

name: opensesame_3.1.9-py2.7-win32-1
channels:
- cogsci
- defaults
dependencies:
- python==2.7.12
- anaconda-client=1.4.0=py27_0
- backports=1.0=py27_0
- backports_abc=0.4=py27_0
- bzip2=1.0.6=vc9_3
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.0.3=py_0
- psychopy=1.82.01=py27_0
- pygame=1.9.2a0=py27_0
# - pyglet=1.2.4=py27_0 # As of 3.1.8 installed through pip so that we can pip update it
- python-datamatrix=0.6.3=py_0 # updated in 3.1.8
- python-fileinspector=1.0.2=py_0 # updated in 3.1.3
- python-opensesame=3.1.9=py_0 # updated in 3.1.9
- python-pseudorandom=0.2.2=py27_0
- python-pygaze=0.6.0a21=py_0 # Updated in 3.1.3
- python-qdatamatrix=0.1.16=py_0 # updated in 3.1.8
- python-qnotifications=1.1.1=py_0 # updated in 3.1.3
- python-qosf=1.2.2=py_0 # updated in 3.1.7
- python-qprogedit=4.0.11=py_0 # updated in 3.1.7
- qscintilla2=2.9.1=py27_vc9_0
- requests-oauthlib=0.6.1=py_0
- webcolors=1.5=py27_0
- configparser=3.5.0b2=py27_1
- decorator=4.0.10=py27_0
- entrypoints=0.2.2=py27_0
- freetype=2.5.5=vc9_1
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- ipykernel=4.3.1=py27_0
- ipython=4.2.0=py27_0
- ipython_genutils=0.1.0=py27_0
- ipywidgets=4.1.1=py27_0
- jinja2=2.8=py27_1
- jpeg=8d=vc9_0
- jsonschema=2.5.1=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=4.3.0=py27_0
- jupyter_console=4.1.1=py27_0
- jupyter_core=4.1.0=py27_0
- libpng=1.6.22=vc9_0
- libtiff=4.0.6=vc9_2
- markdown=2.6.6=py27_0
- markupsafe=0.23=py27_2
- mistune=0.7.2=py27_0
- mkl=11.3.3=1
- nbconvert=4.2.0=py27_0
- nbformat=4.0.1=py27_0
- notebook=4.2.1=py27_0
- numpy=1.11.1=py27_0
- openssl=1.0.2h=vc9_0
- path.py=8.2.1=py27_0
- pickleshare=0.5=py27_0
- pillow=3.2.0=py27_1
- pip=8.1.2=py27_0
- pyflakes=1.2.3=py27_0
- pygments=2.1.3=py27_0
- pyopengl=3.1.1a1=np111py27_0
- pyopengl-accelerate=3.1.1a1=np111py27_0
- pyqt=4.11.4=py27_6
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.12=0
- python-dateutil=2.5.3=py27_0
- pytz=2016.4=py27_0
- pyyaml=3.11=py27_4
- pyzmq=15.2.0=py27_0
- qt=4.8.7=vc9_8
- qtawesome=0.3.3=py27_0
- qtconsole=4.2.1=py27_0
- qtpy=1.0.2=py27_0
- requests=2.10.0=py27_0
- scipy=0.17.1=np111py27_1
- setuptools=23.0.0=py27_0
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.16.9=py27_2
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.4.0.2=py27_1
- tornado=4.3=py27_1
- traitlets=4.2.1=py27_0
- vs2008_runtime=9.00.30729.1=2
- wheel=0.29.0=py27_0
- yaml=0.1.6=0
- zlib=1.2.8=vc9_3
- pip:
  - python-qtpip==0.1.5 # New in 3.1.9
  - pyglet==1.2.4
  - cffi==1.7.0
  - expyriment==0.8.0 # Upgrade manually to 0.8.1.opensesame2
  - imageio==1.5
  - mediadecoder==0.1.5
  - moviepy==0.2.2.11  
  - opensesame-extension-osf==1.1.1 # Updated in 3.1.7
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-windows-launcher==0.4.1
  - pycparser==2.14
  - python-bidi==0.4.0
  - sounddevice==0.3.3
  - tqdm==4.7.6
  - pyaudio==0.2.9 # Added in 3.1.3
  - openpyxl==2.4.0 # Added in 3.1.3
  - fastnumbers==1.0.0 # Added in 3.1.5
  - prettytable==0.7.2 # Added in 3.1.5
prefix: opensesame_3.1.9-py2.7-win32-1
yaml

3.1.8 Jazzy James (8th maintenance release)

@smathot smathot released this Aug 10, 2017 · 6 commits to master since this release

About this update

OpenSesame 3.1.8 Jazzy James is the eight maintenance release in the 3.1 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.1 series.

If you are upgrading from OpenSesame 3.0 or earlier, please see the list of important changes:

Credits

Thanks to:

  • Jarik den Hartog (@JdenHartog) for his code contributions
  • Ronald Sprouse (@rsprouse) for his code contributions
  • Eduard Ort (@eort) for his code contributions
  • Daniel Schreij (@dschreij) for his work on the Mac OS package

Bug fixes and improvements

opensesame:

datamatrix:

  • Updated to 0.6.3

qdatamatrix:

  • Updated to 0.1.16

Packages (Windows Python 2.7 package)

Detailed package information

name: opensesame_3.1.8-py2.7-win32-1
channels:
- cogsci
- defaults
dependencies:
- python==2.7.12
- anaconda-client=1.4.0=py27_0
- backports=1.0=py27_0
- backports_abc=0.4=py27_0
- bzip2=1.0.6=vc9_3
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.0.3=py_0
- psychopy=1.82.01=py27_0
- pygame=1.9.2a0=py27_0
# - pyglet=1.2.4=py27_0 # As of 3.1.8 installed through pip so that we can pip update it
- python-datamatrix=0.6.3=py_0 # updated in 3.1.8
- python-fileinspector=1.0.2=py_0 # updated in 3.1.3
- python-opensesame=3.1.8=py_0 # updated in 3.1.8
- python-pseudorandom=0.2.2=py27_0
- python-pygaze=0.6.0a21=py_0 # Updated in 3.1.3
- python-qdatamatrix=0.1.16=py_0 # updated in 3.1.8
- python-qnotifications=1.1.1=py_0 # updated in 3.1.3
- python-qosf=1.2.2=py_0 # updated in 3.1.7
- python-qprogedit=4.0.11=py_0 # updated in 3.1.7
- qscintilla2=2.9.1=py27_vc9_0
- requests-oauthlib=0.6.1=py_0
- webcolors=1.5=py27_0
- configparser=3.5.0b2=py27_1
- decorator=4.0.10=py27_0
- entrypoints=0.2.2=py27_0
- freetype=2.5.5=vc9_1
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- ipykernel=4.3.1=py27_0
- ipython=4.2.0=py27_0
- ipython_genutils=0.1.0=py27_0
- ipywidgets=4.1.1=py27_0
- jinja2=2.8=py27_1
- jpeg=8d=vc9_0
- jsonschema=2.5.1=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=4.3.0=py27_0
- jupyter_console=4.1.1=py27_0
- jupyter_core=4.1.0=py27_0
- libpng=1.6.22=vc9_0
- libtiff=4.0.6=vc9_2
- markdown=2.6.6=py27_0
- markupsafe=0.23=py27_2
- mistune=0.7.2=py27_0
- mkl=11.3.3=1
- nbconvert=4.2.0=py27_0
- nbformat=4.0.1=py27_0
- notebook=4.2.1=py27_0
- numpy=1.11.1=py27_0
- openssl=1.0.2h=vc9_0
- path.py=8.2.1=py27_0
- pickleshare=0.5=py27_0
- pillow=3.2.0=py27_1
- pip=8.1.2=py27_0
- pyflakes=1.2.3=py27_0
- pygments=2.1.3=py27_0
- pyopengl=3.1.1a1=np111py27_0
- pyopengl-accelerate=3.1.1a1=np111py27_0
- pyqt=4.11.4=py27_6
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.12=0
- python-dateutil=2.5.3=py27_0
- pytz=2016.4=py27_0
- pyyaml=3.11=py27_4
- pyzmq=15.2.0=py27_0
- qt=4.8.7=vc9_8
- qtawesome=0.3.3=py27_0
- qtconsole=4.2.1=py27_0
- qtpy=1.0.2=py27_0
- requests=2.10.0=py27_0
- scipy=0.17.1=np111py27_1
- setuptools=23.0.0=py27_0
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.16.9=py27_2
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.4.0.2=py27_1
- tornado=4.3=py27_1
- traitlets=4.2.1=py27_0
- vs2008_runtime=9.00.30729.1=2
- wheel=0.29.0=py27_0
- yaml=0.1.6=0
- zlib=1.2.8=vc9_3
- pip:
  - pyglet==1.2.4
  - cffi==1.7.0
  - expyriment==0.8.0 # Upgrade manually to 0.8.1.opensesame2
  - imageio==1.5
  - mediadecoder==0.1.5
  - moviepy==0.2.2.11  
  - opensesame-extension-osf==1.1.1 # Updated in 3.1.7
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-windows-launcher==0.4.1
  - pycparser==2.14
  - python-bidi==0.4.0
  - sounddevice==0.3.3
  - tqdm==4.7.6
  - pyaudio==0.2.9 # Added in 3.1.3
  - openpyxl==2.4.0 # Added in 3.1.3
  - fastnumbers==1.0.0 # Added in 3.1.5
  - prettytable==0.7.2 # Added in 3.1.5
prefix: opensesame_3.1.8-py2.7-win32-1

3.1.7 Jazzy James (7th maintenance release)

@smathot smathot released this Jul 6, 2017 · 394 commits to koffka since this release

About this update

OpenSesame 3.1.7 Jazzy James is the seventh maintenance release in the 3.1 series. It contains bug fixes and minor improvements, and should be a pleasant and safe upgrade for everyone who is using the 3.1 series.

If you are upgrading from OpenSesame 3.0 or earlier, please see the list of important changes:

http://osdoc.cogsci.nl/3.1/important-changes-3/

Credits

Thanks to:

  • Daniel Schreij (@dschreij) for the Mac OS package, and his code contributions
  • Jarik den Hartog (@JdenHartog) for his code contributions
  • @juliencegarra for his code contributions

Bug fixes and improvements

opensesame:

qprogedit:

  • Updated to 4.0.11

datamatrix:

  • Updated to 0.4.15

qdatamatrix:

  • Updated to 0.1.15

qosf:

  • Updated to 1.2.2

opensesame-extension-osf

  • Updated to 1.1.1

Packages (Windows Python 2.7 package)

Detailed package information

name: opensesame_3.1.7-py2.7-win32-1
channels:
- cogsci
- defaults
dependencies:
- python==2.7.12
- anaconda-client=1.4.0=py27_0
- backports=1.0=py27_0
- backports_abc=0.4=py27_0
- bzip2=1.0.6=vc9_3
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.0.3=py_0
- psychopy=1.82.01=py27_0
- pygame=1.9.2a0=py27_0
- pyglet=1.2.4=py27_0
- python-datamatrix=0.4.15=py_0 # updated in 3.1.7
- python-fileinspector=1.0.2=py_0 # updated in 3.1.3
- python-opensesame=3.1.7=py_0 # updated in 3.1.7
- python-pseudorandom=0.2.2=py27_0
- python-pygaze=0.6.0a21=py_0 # Updated in 3.1.3
- python-qdatamatrix=0.1.15=py_0 # updated in 3.1.7
- python-qnotifications=1.1.1=py_0 # updated in 3.1.3
- python-qosf=1.2.2=py_0 # updated in 3.1.7
- python-qprogedit=4.0.11=py_0 # updated in 3.1.7
- qscintilla2=2.9.1=py27_vc9_0
- requests-oauthlib=0.6.1=py_0
- webcolors=1.5=py27_0
- configparser=3.5.0b2=py27_1
- decorator=4.0.10=py27_0
- entrypoints=0.2.2=py27_0
- freetype=2.5.5=vc9_1
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- ipykernel=4.3.1=py27_0
- ipython=4.2.0=py27_0
- ipython_genutils=0.1.0=py27_0
- ipywidgets=4.1.1=py27_0
- jinja2=2.8=py27_1
- jpeg=8d=vc9_0
- jsonschema=2.5.1=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=4.3.0=py27_0
- jupyter_console=4.1.1=py27_0
- jupyter_core=4.1.0=py27_0
- libpng=1.6.22=vc9_0
- libtiff=4.0.6=vc9_2
- markdown=2.6.6=py27_0
- markupsafe=0.23=py27_2
- mistune=0.7.2=py27_0
- mkl=11.3.3=1
- nbconvert=4.2.0=py27_0
- nbformat=4.0.1=py27_0
- notebook=4.2.1=py27_0
- numpy=1.11.1=py27_0
- openssl=1.0.2h=vc9_0
- path.py=8.2.1=py27_0
- pickleshare=0.5=py27_0
- pillow=3.2.0=py27_1
- pip=8.1.2=py27_0
- pyflakes=1.2.3=py27_0
- pygments=2.1.3=py27_0
- pyopengl=3.1.1a1=np111py27_0
- pyopengl-accelerate=3.1.1a1=np111py27_0
- pyqt=4.11.4=py27_6
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.12=0
- python-dateutil=2.5.3=py27_0
- pytz=2016.4=py27_0
- pyyaml=3.11=py27_4
- pyzmq=15.2.0=py27_0
- qt=4.8.7=vc9_8
- qtawesome=0.3.3=py27_0
- qtconsole=4.2.1=py27_0
- qtpy=1.0.2=py27_0
- requests=2.10.0=py27_0
- scipy=0.17.1=np111py27_1
- setuptools=23.0.0=py27_0
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.16.9=py27_2
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.4.0.2=py27_1
- tornado=4.3=py27_1
- traitlets=4.2.1=py27_0
- vs2008_runtime=9.00.30729.1=2
- wheel=0.29.0=py27_0
- yaml=0.1.6=0
- zlib=1.2.8=vc9_3
- pip:
  - cffi==1.7.0
  - expyriment==0.8.0 # Upgrade manually to 0.8.1.opensesame2
  - imageio==1.5
  - mediadecoder==0.1.5
  - moviepy==0.2.2.11  
  - opensesame-extension-osf==1.1.1 # Updated in 3.1.7
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-windows-launcher==0.4.1
  - pycparser==2.14
  - python-bidi==0.4.0
  - sounddevice==0.3.3
  - tqdm==4.7.6
  - pyaudio==0.2.9 # Added in 3.1.3
  - openpyxl==2.4.0 # Added in 3.1.3
  - fastnumbers==1.0.0 # Added in 3.1.5
  - prettytable==0.7.2 # Added in 3.1.5
prefix: opensesame_3.1.7-py2.7-win32-1

3.1.6 Jazzy James (6th maintenance release)

@smathot smathot released this Feb 7, 2017 · 434 commits to koffka since this release

About this update

OpenSesame 3.1.6 Jazzy James is the sixth maintenance release in the 3.1 series. This release fixes a regression that was introduced in 3.1.5, which caused a crash when multiple linked sketchpads occurred in the same sequence.

If you are upgrading from OpenSesame 3.0 or earlier, please see the list of important changes:

Bug fixes and improvements

OpenSesame:

  • Updated to 3.1.6
  • Issue #508: Crash when there are mulitple linked copies of a sketchpad in the same sequence (Bug) (Major)

Packages (Windows Python 2.7 package)

Detailed package information

name: opensesame_3.1.6-py2.7-win32-1
channels:
- cogsci
- defaults
dependencies:
- python==2.7.12
- anaconda-client=1.4.0=py27_0
- backports=1.0=py27_0
- backports_abc=0.4=py27_0
- bzip2=1.0.6=vc9_3
- clyent=1.2.2=py27_0
- arrow=0.7.0=py_0
- humanize=0.5.1=py_0
- oauthlib=1.0.3=py_0
- psychopy=1.82.01=py27_0
- pygame=1.9.2a0=py27_0
- pyglet=1.2.4=py27_0
- python-datamatrix=0.4.4=py_0 # updated in 3.1.5
- python-fileinspector=1.0.2=py_0 # updated in 3.1.3
- python-opensesame=3.1.6=py_0 # updated in 3.1.6
- python-pseudorandom=0.2.2=py27_0
- python-pygaze=0.6.0a21=py_0 # Updated in 3.1.3
- python-qdatamatrix=0.1.13=py_0 # updated in 3.1.5
- python-qnotifications=1.1.1=py_0 # updated in 3.1.3
- python-qosf=1.1.8=py_0
- python-qprogedit=4.0.9=py_0 # updated in 3.1.5
- qscintilla2=2.9.1=py27_vc9_0
- requests-oauthlib=0.6.1=py_0
- webcolors=1.5=py27_0
- configparser=3.5.0b2=py27_1
- decorator=4.0.10=py27_0
- entrypoints=0.2.2=py27_0
- freetype=2.5.5=vc9_1
- functools32=3.2.3.2=py27_0
- get_terminal_size=1.0.0=py27_0
- ipykernel=4.3.1=py27_0
- ipython=4.2.0=py27_0
- ipython_genutils=0.1.0=py27_0
- ipywidgets=4.1.1=py27_0
- jinja2=2.8=py27_1
- jpeg=8d=vc9_0
- jsonschema=2.5.1=py27_0
- jupyter=1.0.0=py27_3
- jupyter_client=4.3.0=py27_0
- jupyter_console=4.1.1=py27_0
- jupyter_core=4.1.0=py27_0
- libpng=1.6.22=vc9_0
- libtiff=4.0.6=vc9_2
- markdown=2.6.6=py27_0
- markupsafe=0.23=py27_2
- mistune=0.7.2=py27_0
- mkl=11.3.3=1
- nbconvert=4.2.0=py27_0
- nbformat=4.0.1=py27_0
- notebook=4.2.1=py27_0
- numpy=1.11.1=py27_0
- openssl=1.0.2h=vc9_0
- path.py=8.2.1=py27_0
- pickleshare=0.5=py27_0
- pillow=3.2.0=py27_1
- pip=8.1.2=py27_0
- pyflakes=1.2.3=py27_0
- pygments=2.1.3=py27_0
- pyopengl=3.1.1a1=np111py27_0
- pyopengl-accelerate=3.1.1a1=np111py27_0
- pyqt=4.11.4=py27_6
- pyreadline=2.1=py27_0
- pyserial=2.7=py27_0
- python=2.7.12=0
- python-dateutil=2.5.3=py27_0
- pytz=2016.4=py27_0
- pyyaml=3.11=py27_4
- pyzmq=15.2.0=py27_0
- qt=4.8.7=vc9_8
- qtawesome=0.3.3=py27_0
- qtconsole=4.2.1=py27_0
- qtpy=1.0.2=py27_0
- requests=2.10.0=py27_0
- scipy=0.17.1=np111py27_1
- setuptools=23.0.0=py27_0
- simplegeneric=0.8.1=py27_1
- singledispatch=3.4.0.3=py27_0
- sip=4.16.9=py27_2
- six=1.10.0=py27_0
- sqlite=3.13.0=vc9_1
- ssl_match_hostname=3.4.0.2=py27_1
- tornado=4.3=py27_1
- traitlets=4.2.1=py27_0
- vs2008_runtime=9.00.30729.1=2
- wheel=0.29.0=py27_0
- yaml=0.1.6=0
- zlib=1.2.8=vc9_3
- pip:
  - cffi==1.7.0
  - expyriment==0.8.0 # Upgrade manually to 0.8.1.opensesame2
  - imageio==1.5
  - mediadecoder==0.1.5
  - moviepy==0.2.2.11  
  - opensesame-extension-osf==1.0.12
  - opensesame-plugin-media-player-mpy==0.1.6
  - opensesame-windows-launcher==0.4.1
  - pycparser==2.14
  - python-bidi==0.4.0
  - sounddevice==0.3.3
  - tqdm==4.7.6
  - pyaudio==0.2.9 # Added in 3.1.3
  - openpyxl==2.4.0 # Added in 3.1.3
  - fastnumbers==1.0.0 # Added in 3.1.5
  - prettytable==0.7.2 # Added in 3.1.5
prefix: opensesame_3.1.6-py2.7-win32-1