Skip to content
Newer
Older
100644 63 lines (57 sloc) 1.98 KB
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
0288b5e @snusnu Finished renaming to dm-do-adapter
snusnu authored
7 s.name = %q{dm-do-adapter}
4d3a9e3 @solnic Regenerated gemspec for 1.1.1
solnic authored
8 s.version = "1.1.1"
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
9
aac68fe @dkubb Updated gemspec
dkubb authored
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
11 s.authors = ["Dan Kubb"]
2b5c435 @solnic Bump DO dep to 0.10.6
solnic authored
12 s.date = %q{2011-05-23}
0288b5e @snusnu Finished renaming to dm-do-adapter
snusnu authored
13 s.description = %q{DataObjects Adapter for DataMapper}
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
14 s.email = %q{dan.kubb@gmail.com}
15 s.extra_rdoc_files = [
7222db6 @snusnu This is a proper gem now
snusnu authored
16 "LICENSE",
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
17 "README.rdoc"
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
18 ]
19 s.files = [
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
20 "Gemfile",
21 "LICENSE",
22 "README.rdoc",
23 "Rakefile",
24 "VERSION",
25 "dm-do-adapter.gemspec",
26 "lib/dm-do-adapter.rb",
27 "lib/dm-do-adapter/adapter.rb",
28 "lib/dm-do-adapter/spec/shared_spec.rb",
29 "tasks/yard.rake",
30 "tasks/yardstick.rake"
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
31 ]
0288b5e @snusnu Finished renaming to dm-do-adapter
snusnu authored
32 s.homepage = %q{http://github.com/datamapper/dm-do-adapter}
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
33 s.require_paths = ["lib"]
84dc637 @dkubb Updated Rakefile to be more consistent with other gems
dkubb authored
34 s.rubyforge_project = %q{datamapper}
2b5c435 @solnic Bump DO dep to 0.10.6
solnic authored
35 s.rubygems_version = %q{1.6.2}
0288b5e @snusnu Finished renaming to dm-do-adapter
snusnu authored
36 s.summary = %q{DataObjects Adapter for DataMapper}
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
37
38 if s.respond_to? :specification_version then
39 s.specification_version = 3
40
c18c85b @dkubb Regenerated gemspec for version 1.0.0.rc2
dkubb authored
41 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
2b5c435 @solnic Bump DO dep to 0.10.6
solnic authored
42 s.add_runtime_dependency(%q<data_objects>, ["~> 0.10.6"])
ea5510a @snusnu Bump DM dependencies to ~> 1.1.1
snusnu authored
43 s.add_runtime_dependency(%q<dm-core>, ["~> 1.1.1"])
94a5bb9 @dkubb Regenerated gemspec
dkubb authored
44 s.add_development_dependency(%q<jeweler>, ["~> 1.5.2"])
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
45 s.add_development_dependency(%q<rake>, ["~> 0.8.7"])
46 s.add_development_dependency(%q<rspec>, ["~> 1.3.1"])
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
47 else
2b5c435 @solnic Bump DO dep to 0.10.6
solnic authored
48 s.add_dependency(%q<data_objects>, ["~> 0.10.6"])
ea5510a @snusnu Bump DM dependencies to ~> 1.1.1
snusnu authored
49 s.add_dependency(%q<dm-core>, ["~> 1.1.1"])
94a5bb9 @dkubb Regenerated gemspec
dkubb authored
50 s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
51 s.add_dependency(%q<rake>, ["~> 0.8.7"])
52 s.add_dependency(%q<rspec>, ["~> 1.3.1"])
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
53 end
54 else
2b5c435 @solnic Bump DO dep to 0.10.6
solnic authored
55 s.add_dependency(%q<data_objects>, ["~> 0.10.6"])
ea5510a @snusnu Bump DM dependencies to ~> 1.1.1
snusnu authored
56 s.add_dependency(%q<dm-core>, ["~> 1.1.1"])
94a5bb9 @dkubb Regenerated gemspec
dkubb authored
57 s.add_dependency(%q<jeweler>, ["~> 1.5.2"])
fc1e4f0 @dkubb Updated jeweler dep to 1.5.2
dkubb authored
58 s.add_dependency(%q<rake>, ["~> 0.8.7"])
59 s.add_dependency(%q<rspec>, ["~> 1.3.1"])
02b0c6b @solnic Added dm-data_objects-adapter extracted from dm-core
solnic authored
60 end
61 end
62
Something went wrong with that request. Please try again.