Permalink
Browse files

imlib2: require x11

imlib2 without x11 has missing symbols needed by other programs
like feh.  Add a `depends_on :x11`.  Remove the deps on libpng
and freetype. Works well with superenv.

Fixes #15325

Closes #15390.

Signed-off-by: Adam Vandenberg <flangy@gmail.com>
  • Loading branch information...
1 parent f055a46 commit 27be4f3e9a1f8a5db686d11a032b8aad17ac91c1 nibbles 2bits committed with adamv Oct 10, 2012
Showing with 2 additions and 3 deletions.
  1. +2 −3 Library/Formula/imlib2.rb
@@ -6,15 +6,14 @@ class Imlib2 < Formula
sha1 'af86a2c38f4bc3806db57e64e74dc9814ad474a0'
depends_on 'pkg-config' => :build
- depends_on :freetype
- depends_on :libpng => :recommended
depends_on 'jpeg' => :recommended
+ depends_on :x11
def install
system "./configure", "--disable-dependency-tracking",
"--prefix=#{prefix}",
"--enable-amd64=no",
- "--without-x"
+ "--with-x"
system "make install"
end

0 comments on commit 27be4f3

Please sign in to comment.