Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

mpich2: Update to 1.5

Closes #15396.

Signed-off-by: Charlie Sharpsteen <source@sharpsteen.net>
  • Loading branch information...
commit 45fb5b61529c262978bbb5e0d595534b82406342 1 parent 105fa73
@goodell goodell authored Sharpie committed
Showing with 4 additions and 15 deletions.
  1. +4 −15 Library/Formula/mpich2.rb
View
19 Library/Formula/mpich2.rb
@@ -2,19 +2,13 @@
class Mpich2 < Formula
homepage 'http://www.mcs.anl.gov/research/projects/mpich2/index.php'
- url 'http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/1.4.1p1/mpich2-1.4.1p1.tar.gz'
- version '1.4.1p1'
- sha1 '8dcc8888fb27232eb8f76c11cc890f1c3c483804'
+ url 'http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/1.5/mpich2-1.5.tar.gz'
+ version '1.5'
+ sha1 'be7448227dde5badf3d6ebc0c152b200998421e0'
head 'https://svn.mcs.anl.gov/repos/mpi/mpich2/trunk'
- devel do
- url 'http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/1.5b1/mpich2-1.5b1.tar.gz'
- version '1.5b1'
- sha1 'd9dfc992657c3cbe5b40374fd8aaa553ebaf5402'
- end
-
# the HEAD version requires the autotools to be installed
- # (autoconf>=2.67, automake>=1.11, libtool>=2.4)
+ # (autoconf>=2.67, automake>=1.12.3, libtool>=2.4)
if ARGV.build_head?
depends_on 'automake' => :build
depends_on 'libtool' => :build
@@ -27,11 +21,6 @@ def options
end
def install
- unless ARGV.build_devel? or ARGV.build_head?
- # parallel builds are broken prior to version 1.5a1
- ENV.deparallelize
- end
-
if ARGV.build_head?
# ensure that the consistent set of autotools built by homebrew is used to
# build MPICH2, otherwise very bizarre build errors can occur
Please sign in to comment.
Something went wrong with that request. Please try again.