Please add support for errors 1.4.0 #27

Closed
peti opened this Issue Feb 4, 2013 · 2 comments

2 participants

@peti

Heist won't compile against the latest version of the errors package. If there is a chance, could you please release a quick update that remedies this issue? The error message I get trying to compile Heist is:

src/Heist.hs:140:30:
    Not in scope: type constructor or class `EitherT'
    Perhaps you meant one of these:
      `Either' (imported from Prelude),
      `EitherR' (imported from Control.Error),
      `EitherRT' (imported from Control.Error)
@mightybyte
Snap Framework member

This is due to a bug in the errors package no longer exporting EitherT. It should automatically resolve itself with the next release of errors.

@peti

You were right -- the issue has been fixed by the latest update of errors. Thanks!

@peti peti closed this Feb 7, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment