libev foreign import unsafe error #133

Closed
ghost opened this Issue May 6, 2012 · 1 comment

Comments

Projects
None yet
1 participant
@ghost

ghost commented May 6, 2012

This is all I have to go on. Let me know if there's anything I can do to help figure this out. I had a server running for a few days with -N2, handling about 1000 requests/second. It took a long while to get to this error, so reproducing it is probably not a trivial thing to do.

server-name: server-name: schedule: re-entered unsafely.
Perhaps a 'foreign import unsafe' should be 'safe'?
NetworkziLibev_d1yN: Return code (0) not ok

I am using libev-0.4.0, snap-0.8.0.2, snap-core-0.8.1, snap-server-0.8.1.1, libev 4.03, and ghc 7.0.4.

Jeff

@gregorycollins

This comment has been minimized.

Show comment
Hide comment
@gregorycollins

gregorycollins May 7, 2012

Member

Hi,

We're getting rid of the libev backend for 0.9, because of issues like this and because the slight increase in performance is not worth the burden of maintaining a separate parallel server backend. I suggest just switching to the normal backend, which is nearly as fast anyways.

Member

gregorycollins commented May 7, 2012

Hi,

We're getting rid of the libev backend for 0.9, because of issues like this and because the slight increase in performance is not worth the burden of maintaining a separate parallel server backend. I suggest just switching to the normal backend, which is nearly as fast anyways.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment