Installing on Haskell-Platform 2012 #141

Closed
pooster opened this Issue Jun 10, 2012 · 1 comment

Comments

Projects
None yet
2 participants

pooster commented Jun 10, 2012

Came across this error when installing on haskell-platform 2012. On irc some have said it was due to heist.

cabal install snap
Resolving dependencies...
In order, the following would be installed:
PSQueue-1.1 (new package)
attoparsec-0.10.2.0 (new package)
base16-bytestring-0.1.1.4 (new package)
base64-bytestring-0.1.1.1 (new package)
blaze-builder-0.3.1.0 (new package)
blaze-html-0.4.3.4 (new package)
bytestring-mmap-0.2.2 (new package)
bytestring-nums-0.3.5 (new package)
cereal-0.3.5.2 (new package)
cpu-0.1.0 (new package)
directory-tree-0.10.0 (new package)
dlist-0.5 (new package)
entropy-0.2.1 (new package)
hashable-1.1.2.3 (new package)
case-insensitive-0.4.0.1 (new package)
largeword-1.0.1 (new package)
murmur-hash-0.1.0.5 (new package)
primitive-0.4.1 (new package)
semigroups-0.8.3.2 (new package)
tagged-0.4.2.1 (new package)
crypto-api-0.10.2 (new package)
crypto-pubkey-types-0.1.1 (new package)
cryptohash-0.7.5 (new package)
pwstore-fast-2.2 (new package)
skein-0.1.0.7 (new package)
transformers-0.2.2.0 (new version)
MonadCatchIO-transformers-0.2.2.3 (new package)
comonad-1.1.1.6 (new package)
contravariant-0.2.0.2 (new package)
distributive-0.2.2 (new package)
enumerator-0.4.19 (new package)
attoparsec-enumerator-0.3 (new package)
blaze-builder-enumerator-0.2.0.4 (new package)
mtl-2.0.1.0 (new version)
logict-0.5.0.1 (new package)
parsec-3.1.2 (reinstall) changes: mtl-2.1.1 -> 2.0.1.0
network-2.3.0.14 (new version)
regex-base-0.93.2 (reinstall) changes: mtl-2.1.1 -> 2.0.1.0
regex-posix-0.95.2 (new version)
semigroupoids-1.3.2.1 (new package)
comonad-transformers-2.1.1.1 (new package)
data-lens-2.10.0 (new package)
data-lens-template-2.1.5 (new package)
unix-compat-0.3.0.1 (new package)
unordered-containers-0.2.1.0 (new package)
configurator-0.2.0.0 (new package)
utf8-string-0.3.7 -bytestring-in-base (new package)
vector-0.9.1 (new package)
aeson-0.6.0.2 (new package)
cryptocipher-0.3.4 (new package)
cprng-aes-0.2.3 (new package)
clientsession-0.7.5 (new package)
mwc-random-0.12.0.0 (new package)
vector-algorithms-0.5.4 (new package)
xmlhtml-0.1.7 (new package)
heist-0.8.0 (new package)
zlib-bindings-0.1.0.1 (new package)
zlib-enum-0.2.2.1 (new package)
snap-core-0.8.1 (new package)
snap-server-0.8.1.1 (new package)
snap-0.8.1 (new package)

cabal: The following packages are likely to be broken by the reinstalls:
network-2.3.0.13
haskell-platform-2012.2.0.0
cgi-3001.1.7.4
HTTP-4000.2.3
regex-posix-0.95.1
regex-compat-0.95.1
Use --force-reinstalls if you want to install anyway.

Owner

gregorycollins commented Jun 13, 2012

This is already fixed on the git master branch and will be released this weekend.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment