@snipe snipe released this Nov 21, 2017 · 1020 commits to master since this release

Assets 2

New in v4.1.5

Lots of small fixes in this release, and one bigger fix to handle regression issue in 4.1.4 in which certain licenses would not allow the checkout of anything other than the first seat.

  • Fixed #4457 - use un-escaped CSS for custom CSS styles
  • Fixed #4450 - added MAIL_REPLYTO_ADDR to docker.env
  • Fixed #4428 - updated translations
  • Fixed #4408 - requestable assets "request" button not working
  • Improved - removed 500 pixel width on 2FA dropdown
  • Fixed #4471 - removed gate for categories selectlist
  • Fixed sort by model in asset listing
  • Fixed #4440 - allow username search in asset dropdown
  • Fixed location sorting location_id instead of rtd_location_id, which was causing weird results
  • Improved - upgrade language in upgrade.php
  • Fixed #4413 - Next license seat not bering assigned correctly

Documentation

We've also made some improvements to the User's Manual:

If your locations don't seem to be reporting correctly, you can try running php artisan snipeit:sync-asset-locations --output=all to sync them up with where they should be. (This could have happened if your migration that de-normalized the locations didn't work properly.)

For upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

If you get a composer error about AWS, like PHP Fatal error: Class 'Aws\Laravel\AwsServiceProvider' not found [Symfony\Component\Debug\Exception\FatalErrorException]:

  • delete the files (not the directory) in bootstrap/cache
  • run composer dump-autoload
  • remove config/aws.php if it exists

For a full list of changes, see the changelog.

Known Issues

This version requires the php-curl extension library to be installed. (php-curl is in the overall requirements for Snipe-IT but you could get away with not having that extension loaded previously.) Composer install will fail if you do not have php-curl enabled, however php-curl is a common package and is most likely already installed/enabled.

Users running MariaDB 10.2.7 and later may have an issue upgrading or installing, due to a change in the way MariaDB stores null defaults. This issue will be fixed once the open pull request in the Doctrine repo is merged and a new version of Doctrine is released with these fixes. You can read more about that issue here.

After completing the upgrade process below, be sure to clear your browser cookies.

Upgrading from v3

Please see the upgrade instructions here.