Skip to content

@snipe snipe released this May 6, 2019 · 11 commits to master since this release

New in v4.6.16

Version 4.6.16 of Snipe-IT introduces a few small features and includes a bugfix for users who are getting an empty Assets listing if they have a null EOL date set for some or all assets.

New Audit Due / Audit Report Email Alerts and Web View

Screen Shot 2019-05-05 at 10 45 50 PM

If you're already using the built-in scheduler, this will be included automatically. To run it manually, you would use php artisan snipeit:upcoming-audits.

Screen Shot 2019-05-05 at 7 42 44 PM

This adds two new sidenav items into the Assets menu that bring you to a report of assets that are due soon (using whatever your audit threshold is set to in Admin Settings > Notifications) and what is overdue.

Screen Shot 2019-05-05 at 7 39 18 PM

Screen Shot 2019-05-05 at 7 39 09 PM

Upcoming/Overdue Audit API Endpoints

Two new GET endpoints have been added, /api/v1/hardware/audit/due and /api/v1/hardware/audit/overdue.

These actually use the main index Asset API controller, because there would have been a lot of copypasta otherwise, and that method is already a workhorse, but we wanted to provide a more semantic endpoint.

Added:

  • Allow phone number to be changed in Edit Profile
  • Added #6204 - added email alerts and web/API access to assets due or overdue for audit

Fixed:

  • Fixed #6922 - date_add crashing if EOL is null
  • Remove “Imported from LDAP” note override
  • Fixed #6911 - note must be a string on license checkin

Upgrading

For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

For a full list of changes, see the changelog.

IMPORTANT: This will be one of the final releases of Snipe-IT that will work with PHP5. Future versions of Snipe-IT will require PHP 7.1.3 or greater. Please start upgrading your versions of PHP to 7.1.3 to prepare for the next major release. There may be a few small bug fix releases before Snipe-IT v5, but you should start preparing now.

Known Issues

Snipe-IT v4.x is not compatible with PHP 7.3. You'll need to use a version of PHP between 5.6.4 and 7.2.x. This is due to a limitation of the underlying framework. The upcoming v5 will support 7.3+.

Users running MariaDB 10.2.7 and later may have an issue upgrading or installing, due to a change in the way MariaDB stores null defaults. This issue will be fixed once the open pull request in the Doctrine repo is merged and a new version of Doctrine is released with these fixes. You can read more about that issue here.

After completing the upgrade process below, be sure to clear your browser cookies.

Upgrading from v3

Please see the upgrade instructions here.

Assets 2
You can’t perform that action at this time.