Skip to content

@snipe snipe released this Feb 13, 2019 · 42 commits to master since this release

New in v4.6.9

This is a minor bugfix release that addresses a few small API issues, and a few issues affecting user management.

For the API, we now return a 200 error instead of a 404 error when you search for an asset using the byTag() endpoint, which makes it consistent with the rest of the API. Additionally, if you send blank values to the asset update endpoint, those values will now be correctly nulled. (Previously they would not be, and the original value would be unchanged.)

For the web UI, we fixed a bug where if a location a user was the manager of was deleted, the user could not be deleted. We now no longer count deleted locations against that user deletion eligibility check. And finally, we fixed a bug where a user that previously had permissions groups assigned could not be removed from all groups. (You could control+click to deselect it, but the deselection would not be honored on save.)

API: Fixed

  • Fixed #6633 - return 200 (was 404) status code on asset by tag endpoint [BREAKING]
  • Fixed #6113 - use $asset->fill() vs filled() to allow blanking values via API
  • User notes field is now editable via API

Web UI: Fixed

  • Do not count deleted locations in managedLocations() check on user delete
  • Fixed #6061 - Allow the deselection of all user groups on user edit


For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

For a full list of changes, see the changelog.

IMPORTANT: This will be one of the final releases of Snipe-IT that will work with PHP5. Future versions of Snipe-IT will require PHP 7.1.3 or greater. Please start upgrading your versions of PHP to 7.1.3 to prepare for the next major release. There may be a few small bug fix releases before Snipe-IT v5, but you should start preparing now.

Known Issues

Snipe-IT v4.x is not compatible with PHP 7.3. You'll need to use a version of PHP between 5.6.4 and 7.2.x. This is due to a limitation of the underlying framework. The upcoming v5 will support 7.3+.

Users running MariaDB 10.2.7 and later may have an issue upgrading or installing, due to a change in the way MariaDB stores null defaults. This issue will be fixed once the open pull request in the Doctrine repo is merged and a new version of Doctrine is released with these fixes. You can read more about that issue here.

After completing the upgrade process below, be sure to clear your browser cookies.

Upgrading from v3

Please see the upgrade instructions here.

Assets 2
You can’t perform that action at this time.