Skip to content

@snipe snipe released this May 28, 2019 · 29 commits to master since this release

New in v4.7.0

IMPORTANT: This release requires PHP 7.1.3 or greater. This version of Snipe-IT is compatible with PHP 7.3.

We've updated all of the package dependencies in this release and fixed a few small edge-case bugs. Users are encouraged to upgrade to v4.7 as soon as possible, as this release includes some security fixes for the underlying framework and package dependencies.

Added:

  • Upgraded Laravel framework to 5.5

Fixed:

  • Small fix for reordering fields in a fieldset
  • Fixed bug where sorting by company name in Users API did not work
  • Removed custom fields from AssignedSearch() to prevent confusing data in results
  • Fixed Undefined variable user in $backto if asset is checked out to a non-user
  • Check for valid model before attempting to access fieldsets on that model
  • Fixed #7083 - Removed user_exists constraint on department save

Improved:

  • Increased image resize size to 800px, added lightboxes

Upgrading

For general upgrading instructions, click here. Users who installed Snipe-IT via Git (recommended) can just run php upgrade.php.

For a full list of changes, see the changelog.

After completing the upgrade process, be sure to clear your browser cookies.

Upgrading from v3

Please see the upgrade instructions here.

Assets 2
You can’t perform that action at this time.