Permalink
Browse files

Change bootstrap.sh to require Cabal >= 1.16 && < 1.18

  • Loading branch information...
1 parent e99e308 commit 6c5d8448d25b49911614cebc988d94974926e97f @tibbe tibbe committed Oct 11, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 cabal-install/bootstrap.sh
@@ -51,7 +51,7 @@ PARSEC_VER="3.1.3"; PARSEC_VER_REGEXP="[23]\." # == 2.* || == 3.*
DEEPSEQ_VER="1.3.0.1"; DEEPSEQ_VER_REGEXP="1\.[1-9]\." # >= 1.1 && < 2
TEXT_VER="0.11.2.3"; TEXT_VER_REGEXP="0\.([2-9]|(1[0-1]))\." # >= 0.2 && < 0.12
NETWORK_VER="2.3.1.1"; NETWORK_VER_REGEXP="2\." # == 2.*
-CABAL_VER="1.16.0"; CABAL_VER_REGEXP="1\.(13\.3|1[4-7]\.)" # >= 1.13.3 && < 1.18
+CABAL_VER="1.16.0"; CABAL_VER_REGEXP="1\.1[67]\." # >= 1.16 && < 1.18
TRANS_VER="0.3.0.0"; TRANS_VER_REGEXP="0\.[23]\." # >= 0.2.* && < 0.4.*
MTL_VER="2.1.2"; MTL_VER_REGEXP="[12]\." # == 1.* || == 2.*
HTTP_VER="4000.2.4"; HTTP_VER_REGEXP="4000\.[012]\." # == 4000.0.* || 4000.1.* || 4000.2.*

0 comments on commit 6c5d844

Please sign in to comment.