Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Knocked version down to 0.3

  • Loading branch information...
commit eb323568c603fb60a5c32cf0730888e661836980 1 parent ee6c2f7
@snoyberg authored
Showing with 1 addition and 1 deletion.
  1. +1 −1  yaml.cabal
View
2  yaml.cabal
@@ -1,5 +1,5 @@
name: yaml
-version: 0.5.0
+version: 0.3.0
license: BSD3
license-file: LICENSE
author: Michael Snoyman <michael@snoyman.com>

2 comments on commit eb32356

@antage

$ ghc-pkg unregister yaml
$ cabal configure
Resolving dependencies...
Configuring yaml-0.3.0...
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
package control-monad-failure-0.6.0 requires transformers-0.1.4.0
package yaml-0.3.0 requires transformers-0.2.1.0
package iteratee-0.3.5 requires transformers-0.2.1.0
package MonadCatchIO-transformers-0.2.2.0 requires transformers-0.2.1.0

$ cabal install
Resolving dependencies...
cabal: cannot configure control-monad-failure-0.6.0. It requires transformers

=0.1.4.0 && <0.2
For the dependency on transformers >=0.1.4.0 && <0.2 there are these packages:
transformers-0.1.4.0. However none of them are available.
transformers-0.1.4.0 was excluded because iteratee-0.3.5 requires transformers
=0.2.0.0 && <0.3
transformers-0.1.4.0 was excluded because MonadCatchIO-transformers-0.2.2.0
requires transformers ==0.2.*

@snoyberg
Owner

I think you need to do a cabal update; control-monad-failure should be at a higher version that supports transformers 0.2.*.

By the way, you can e-mail instead if you like: michael@snoyman.com

Please sign in to comment.
Something went wrong with that request. Please try again.