Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bump to 1.1.1 and update the gemspec (generation)

  • Loading branch information...
commit d14923a953b19dac3d8f08031c9a758bde65ffa9 1 parent 2a9becc
@snusnu authored
Showing with 26 additions and 17 deletions.
  1. +8 −4 Rakefile
  2. +16 −11 dm-pager.gemspec
  3. +2 −2 lib/dm-pager/version.rb
View
12 Rakefile
@@ -10,9 +10,13 @@ Echoe.new "dm-pager", DataMapper::Pagination::VERSION do |p|
p.email = "tj@vision-media.ca"
p.summary = "DataMapper Pagination"
p.url = "http://github.com/visionmedia/dm-pagination"
- p.runtime_dependencies = []
- p.runtime_dependencies << 'dm-core >=0.10.1'
- p.runtime_dependencies << 'dm-aggregates >=0.10.1'
+
+ p.runtime_dependencies = []
+ p.runtime_dependencies << 'dm-core ~>1.1.0'
+ p.runtime_dependencies << 'dm-aggregates ~>1.1.0'
+ p.development_dependencies = []
+ p.development_dependencies << 'dm-migrations ~>1.1.0'
+ p.development_dependencies << 'dm-sqlite-adapter ~>1.1.0'
end
-Dir['tasks/**/*.rake'].sort.each { |f| load f }
+Dir['tasks/**/*.rake'].sort.each { |f| load f }
View
27 dm-pager.gemspec
@@ -2,11 +2,11 @@
Gem::Specification.new do |s|
s.name = %q{dm-pager}
- s.version = "1.0.3"
+ s.version = "1.1.1"
s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
s.authors = ["TJ Holowaychuk"]
- s.date = %q{2011-03-08}
+ s.date = %q{2011-04-20}
s.description = %q{DataMapper Pagination}
s.email = %q{tj@vision-media.ca}
s.extra_rdoc_files = ["lib/dm-pager.rb", "lib/dm-pager/defaults.rb", "lib/dm-pager/helpers.rb", "lib/dm-pager/helpers/rails.rb", "lib/dm-pager/pager.rb", "lib/dm-pager/pagination.rb", "lib/dm-pager/version.rb", "tasks/docs.rake", "tasks/gemspec.rake", "tasks/spec.rake"]
@@ -15,22 +15,27 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Dm-pager", "--main", "Readme.md"]
s.require_paths = ["lib"]
s.rubyforge_project = %q{dm-pager}
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.7.2}
s.summary = %q{DataMapper Pagination}
if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<dm-core>, [">= 0.10.1"])
- s.add_runtime_dependency(%q<dm-aggregates>, [">= 0.10.1"])
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<dm-core>, ["~> 1.1.0"])
+ s.add_runtime_dependency(%q<dm-aggregates>, ["~> 1.1.0"])
+ s.add_development_dependency(%q<dm-migrations>, ["~> 1.1.0"])
+ s.add_development_dependency(%q<dm-sqlite-adapter>, ["~> 1.1.0"])
else
- s.add_dependency(%q<dm-core>, [">= 0.10.1"])
- s.add_dependency(%q<dm-aggregates>, [">= 0.10.1"])
+ s.add_dependency(%q<dm-core>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-aggregates>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-migrations>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-sqlite-adapter>, ["~> 1.1.0"])
end
else
- s.add_dependency(%q<dm-core>, [">= 0.10.1"])
- s.add_dependency(%q<dm-aggregates>, [">= 0.10.1"])
+ s.add_dependency(%q<dm-core>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-aggregates>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-migrations>, ["~> 1.1.0"])
+ s.add_dependency(%q<dm-sqlite-adapter>, ["~> 1.1.0"])
end
end
View
4 lib/dm-pager/version.rb
@@ -1,6 +1,6 @@
module DataMapper
module Pagination
- VERSION = '1.1.0'
+ VERSION = '1.1.1'
end
-end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.