Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

file 66 lines (62 sloc) 2.224 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-

Gem::Specification.new do |s|
  s.name = "trxl"
  s.version = "0.1.11"

  s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
  s.authors = ["Martin Gamsjaeger (snusnu)", "Michael Aufreiter"]
  s.date = "2012-05-08"
  s.description = "A specced little language written with ruby and treetop. It has lambdas, recursion, conditionals, arrays, hashes, ranges, strings, arithmetics and some other stuff. It even has a small code import facility."
  s.email = "gamsnjaga [at] gmail [dot] com"
  s.extra_rdoc_files = [
    "README"
  ]
  s.files = [
    "README",
    "Rakefile",
    "VERSION",
    "lib/trxl.rb",
    "lib/trxl/trxl.rb",
    "lib/trxl/trxl_grammar.rb",
    "lib/trxl/trxl_grammar.treetop",
    "spec/spec.opts",
    "spec/spec_helper.rb",
    "spec/trxl/arithmetics_spec.rb",
    "spec/trxl/arrays_spec.rb",
    "spec/trxl/booleans_spec.rb",
    "spec/trxl/builtins_spec.rb",
    "spec/trxl/closures_spec.rb",
    "spec/trxl/comments_spec.rb",
    "spec/trxl/common_spec.rb",
    "spec/trxl/conditionals_spec.rb",
    "spec/trxl/constants_spec.rb",
    "spec/trxl/environment_spec.rb",
    "spec/trxl/hashes_spec.rb",
    "spec/trxl/numbers_spec.rb",
    "spec/trxl/ranges_spec.rb",
    "spec/trxl/require_spec.rb",
    "spec/trxl/stdlib_spec.rb",
    "spec/trxl/strings_spec.rb",
    "spec/trxl/variables_spec.rb",
    "trxl.gemspec"
  ]
  s.homepage = "http://github.com/snusnu/trxl"
  s.require_paths = ["lib"]
  s.rubygems_version = "1.8.17"
  s.summary = "A specced little language written with ruby and treetop."

  if s.respond_to? :specification_version then
    s.specification_version = 3

    if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
      s.add_runtime_dependency(%q<treetop>, [">= 1.4"])
      s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
    else
      s.add_dependency(%q<treetop>, [">= 1.4"])
      s.add_dependency(%q<rspec>, [">= 1.2.9"])
    end
  else
    s.add_dependency(%q<treetop>, [">= 1.4"])
    s.add_dependency(%q<rspec>, [">= 1.2.9"])
  end
end
Something went wrong with that request. Please try again.