Permalink
Browse files

tree-wide: drop support for python 3.3

  • Loading branch information...
pope1ni committed Oct 24, 2017
1 parent c57fb2e commit b6f392b27327a4ef1f0b71b19831274c29d1aaff
Showing with 5 additions and 11 deletions.
  1. +0 −5 .travis.yml
  2. +1 −1 CHANGES.md
  3. +1 −1 README.md
  4. +2 −3 setup.py
  5. +1 −1 tox.ini
@@ -2,7 +2,6 @@ sudo: false
language: python
python:
- 2.7
- 3.3
- 3.4
- 3.5
- 3.6
@@ -19,10 +18,6 @@ matrix:
exclude:
- python: 2.7
env: FRAMEWORK=django~=2.0.0
- python: 3.3
env: FRAMEWORK=django~=1.10.0
- python: 3.3
env: FRAMEWORK=django~=1.11.0
fast_finish: true
branches:
except:
@@ -49,7 +49,7 @@ the `soapfish` fork.
- Attempts to fix handling of remote vs local imports.
- **Miscellaneous:**
- Renamed `SoapboxRequest` and `SoapboxResponse` to `SOAPRequest` and `SOAPResponse` respectively.
- Support Python 2.7 and 3.3 - 3.6, and Django 1.11 & 2.0.
- Support Python 2.7 & 3.4 - 3.6 and Django 1.11 & 2.0.
- Improved testing against different versions of Python, Django & Flask.
- Improved entry points for generation scripts - additional flags, etc.
- Moved to using an external dependency for `iso8601`
@@ -27,7 +27,7 @@ Currently the project supports the following:
Other notable features include:
- Support for Python 2.7 and 3.3+
- Support for Python 2.7 and 3.4+
- Licensed under the 3-clause BSD license
- Code generation utilities to get started quickly
- Parsing/serializing a Python class model from/to XML so you can easily work
@@ -9,8 +9,8 @@
import soapfish
if sys.version_info < (2, 7) or (3, 0) <= sys.version_info < (3, 3):
sys.stderr.write('soapfish requires Python 2.7 or 3.3+')
if sys.version_info < (2, 7) or (3, 0) <= sys.version_info < (3, 4):
sys.stderr.write('soapfish requires Python 2.7 or 3.4+')
sys.exit(1)
@@ -76,7 +76,6 @@ def requirements(*filenames):
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.3',
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
@@ -1,5 +1,5 @@
[tox]
envlist = py27, py33, py34, py35, py36
envlist = py27, py34, py35, py36
[testenv]
commands = nosetests --nocapture

0 comments on commit b6f392b

Please sign in to comment.