Failed to require "socket.io" from "root" in 1.0 #520

Closed
cayasso opened this Issue Feb 12, 2013 · 1 comment

Projects

None yet

3 participants

@cayasso

I am getting that error just by including this in my html

<script src="/socket.io/socket.io.js"></script>

I am using socket.io 1.0, any ideas what is going on, or how to resolve?
I even tried loading socket.io-client as component but I get a very similar error message.

I just need to know if this version of the client, can be used (for testing) if not I will just roll back to 0.9.

Best,

JB

@itsnotvalid

It's also noted that the exported component is located at window.eio instead of window.io, as from the current source or the Makefile, all are referring to eio. Probably some leftover from engine.io-client, may be?

@rauchg rauchg closed this Nov 25, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment