Permalink
Browse files

Fix #26. Support websockets for FF 6.0.2

  • Loading branch information...
1 parent b2761c9 commit 33f6ff51eab21d7b2ae2ac9b02d3e2782304a632 @majek majek committed Oct 21, 2011
Showing with 3 additions and 1 deletion.
  1. +3 −1 src/trans-websocket.coffee
@@ -12,7 +12,9 @@ exports.app =
status: 400
message: 'Can "Upgrade" only to "WebSocket".'
}
- if (req.headers.connection || '').toLowerCase() isnt 'upgrade'
+ conn = (req.headers.connection || '').toLowerCase()
+
+ if (conn.split(/, */)).indexOf('upgrade') is -1
throw {
status: 400
message: '"Connection" must be "Upgrade".'

1 comment on commit 33f6ff5

@stephank

Oh, awesome! I briefly wondered why it wasn't using WebSockets, but quickly forgot to look into it or even report it. :B

Please sign in to comment.