Permalink
Browse files

Set minimum GCC version to 4.8, enable travis for 4.8

  • Loading branch information...
milot-mirdita committed Jan 30, 2019
1 parent 013a630 commit 9aa073b8b3156d08cdd66ca223e4d9060a601d09
Showing with 18 additions and 16 deletions.
  1. +17 −15 .travis.yml
  2. +1 −1 CMakeLists.txt
@@ -38,21 +38,22 @@ matrix:
- libopenmpi-dev
env:
- MATRIX_EVAL="CC=clang-7;CXX=clang++-7"
# - os: linux
# dist: trusty
# sudo: false
# addons:
# apt:
# packages:
# - cmake
# - ninja-build
# - g++-4.6
# - zlib1g-dev
# - libbz2-dev
# - vim-common
# - libopenmpi-dev
# env:
# - MATRIX_EVAL="CC=gcc-4.6;CXX=g++-4.6"
- os: linux
dist: trusty
sudo: false
addons:
apt:
packages:
- cmake
- ninja-build
- gcc-4.8
- g++-4.8
- zlib1g-dev
- libbz2-dev
- vim-common
- libopenmpi-dev
env:
- MATRIX_EVAL="CC=gcc-4.8;CXX=g++-4.8"
- os: linux
dist: trusty
sudo: false
@@ -63,6 +64,7 @@ matrix:
packages:
- cmake
- ninja-build
- gcc-8
- g++-8
- zlib1g-dev
- libbz2-dev
@@ -28,7 +28,7 @@ if ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
# using GCC
message("-- Compiler is GNU ")
if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.6.0")
if (CMAKE_CXX_COMPILER_VERSION VERSION_LESS "4.8.0")
message(FATAL_ERROR "Insufficient gcc version")
endif ()
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Intel")

0 comments on commit 9aa073b

Please sign in to comment.