Permalink
Browse files

Add Bundler and upgrade to Ruby 1.9.3

  • Loading branch information...
1 parent d9ef637 commit 962483a897120d4d4d73479c056e93e8a07f5102 @soffes committed Oct 18, 2012
Showing with 42 additions and 13 deletions.
  1. +10 −0 Gemfile
  2. +27 −0 Gemfile.lock
  3. +2 −8 app.rb
  4. +3 −5 config.ru
View
@@ -0,0 +1,10 @@
+source 'https://rubygems.org'
+
+ruby '1.9.3'
+
+gem 'sinatra'
+gem 'thin'
+
+group :development do
+ gem 'shotgun'
+end
View
@@ -0,0 +1,27 @@
+GEM
+ remote: https://rubygems.org/
+ specs:
+ daemons (1.1.9)
+ eventmachine (1.0.0)
+ rack (1.4.1)
+ rack-protection (1.2.0)
+ rack
+ shotgun (0.9)
+ rack (>= 1.0)
+ sinatra (1.3.3)
+ rack (~> 1.3, >= 1.3.6)
+ rack-protection (~> 1.2)
+ tilt (~> 1.3, >= 1.3.3)
+ thin (1.5.0)
+ daemons (>= 1.0.9)
+ eventmachine (>= 0.12.6)
+ rack (>= 1.0.0)
+ tilt (1.3.3)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ shotgun
+ sinatra
+ thin
View
@@ -1,13 +1,7 @@
-require 'rubygems'
-require 'sinatra'
-
-set :app_file, __FILE__
-set :root, File.dirname(__FILE__)
-
before do
- content_type 'text/html', :charset => 'utf-8'
+ content_type 'text/html', charset: 'utf-8'
end
get '/?' do
- erb :home, :locals => { :params => params}
+ erb :home, locals: { params: params}
end
View
@@ -1,8 +1,6 @@
require 'rubygems'
-require 'sinatra'
-require 'app.rb'
-
-set :environment, :production
-set :run, false
+require 'bundler'
+Bundler.require
+require './app'
run Sinatra::Application

0 comments on commit 962483a

Please sign in to comment.