Installation via CocoaPods fails #175

Closed
bromoab opened this Issue Mar 30, 2013 · 1 comment

Comments

Projects
None yet
2 participants

bromoab commented Mar 30, 2013

When I attempt to install SSToolKit via cocoapods v0.17.0 under ruby 2.0 get the following error:

23> pod install
Analyzing dependencies
Downloading dependencies
Using AFNetworking (1.1.0)
Using CocoaLumberjack (1.6)
Using ConciseKit (0.1.2)
Installing SSToolkit (1.0.3)
Generating Pods project
[!] The post install hook of SSToolkit (1.0.3) is not compatible with this version of CocoaPods.

No such file or directory - /Users/bromo/SWDevelopment/iOS/Third Party/tutorials/CocoaPodsExample/Pods/Users/bromo/SWDevelopment/iOS/Third Party/tutorials/CocoaPodsExample/Pods/Pods-resources.sh

/Users/bromo/.cocoapods/master/SSToolkit/1.0.3/SSToolkit.podspec:27:in initialize' /Users/bromo/.cocoapods/master/SSToolkit/1.0.3/SSToolkit.podspec:27:inopen'
/Users/bromo/.cocoapods/master/SSToolkit/1.0.3/SSToolkit.podspec:27:in block in post_install' /Users/bromo/.cocoapods/master/SSToolkit/1.0.3/SSToolkit.podspec:20:inchdir'
/Users/bromo/.cocoapods/master/SSToolkit/1.0.3/SSToolkit.podspec:20:in post_install' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-core-0.17.0/lib/cocoapods-core/specification/dsl/deprecations.rb:24:inblock in singleton_method_added'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-core-0.17.0/lib/cocoapods-core/specification.rb:423:in call' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-core-0.17.0/lib/cocoapods-core/specification.rb:423:inpost_install!'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:459:in run_spec_post_install_hook' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:434:inblock (3 levels) in run_post_install_hooks'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:432:in each' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:432:inblock (2 levels) in run_post_install_hooks'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:430:in each' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:430:inblock in run_post_install_hooks'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/user_interface.rb:113:in message' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:429:inrun_post_install_hooks'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:112:in block in generate_pods_project' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/user_interface.rb:52:insection'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:108:in generate_pods_project' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/installer.rb:86:ininstall!'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/command/project.rb:40:in run_install_with_update' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/command/project.rb:70:inrun'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/claide-0.2.0/lib/claide.rb:535:in run' /opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/lib/cocoapods/command.rb:36:inrun'
/opt/local/lib/ruby2.0/gems/2.0.0/gems/cocoapods-0.17.0/bin/pod:16:in <top (required)>' /opt/local/bin/pod:23:inload'
/opt/local/bin/pod:23:in `

'

NOTE THAT INSTALLATION USING COCOAPODS 0.16.4 WORKS CORRECTLY as shown below

20> pod 0.16.4 install
Resolving dependencies of `./Podfile'
Updating spec repositories

Cocoapods 0.17.0.rc7 is available.

Resolving dependencies for target `default' (iOS 6.0)
Downloading dependencies
Using AFNetworking (1.1.0)
Using CocoaLumberjack (1.6)
Using ConciseKit (0.1.2)
Installing SSToolkit (1.0.3)
Generating support files

21> pod --version
0.17.0
22>

Contributor

plu commented Apr 2, 2013

@soffes soffes closed this in db62ea0 Jun 25, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment