Is this a python <3 problem? #62

Closed
Worthy7 opened this Issue Feb 13, 2014 · 8 comments

Projects

None yet

4 participants

@Worthy7
Worthy7 commented Feb 13, 2014

Tried it out on both SL2 and 3 and both times on startups I get these 2 SYNTAX errors in the console.

Traceback (most recent call last):

File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 73, in reload_plugin

m = importlib.import_module(modulename)

File "X/importlib/init.py", line 88, in import_module

File "", line 1577, in _gcd_import

File "", line 1558, in _find_and_load

File "", line 1525, in _find_and_load_unlocked

File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 671, in load_module

exec(compile(source, source_path, 'exec'), mod.dict)

File "swi in C:\Users[USERNAME]\AppData\Roaming\Sublime Text 3\Installed Packages\SublimeWebInspector.sublime-package", line 71

print 'SWI: Connecting to ' + url

^

SyntaxError: invalid syntax

reloading plugin SublimeWebInspector.websocket

Traceback (most recent call last):

File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 73, in reload_plugin

m = importlib.import_module(modulename)

File "X/importlib/init.py", line 88, in import_module

File "", line 1577, in _gcd_import

File "", line 1558, in _find_and_load

File "", line 1525, in _find_and_load_unlocked

File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 671, in load_module

exec(compile(source, source_path, 'exec'), mod.dict)

File "websocket in C:\Users[USERNAME]\AppData\Roaming\Sublime Text 3\Installed Packages\SublimeWebInspector.sublime-package", line 717

except Exception, e:

^

SyntaxError: invalid syntax

@prabhuanirudhxoriant

Any update on this? Even i'm facing similar issue on ST3

Traceback (most recent call last):
File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 73, in reload_plugin
m = importlib.import_module(modulename)
File "X/importlib/init.py", line 88, in import_module
File "", line 1577, in _gcd_import
File "", line 1558, in _find_and_load
File "", line 1525, in _find_and_load_unlocked
File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 671, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "swi in C:\Users\prabhu_a\AppData\Roaming\Sublime Text 3\Installed Packages\SublimeWebInspector.sublime-package", line 71
print 'SWI: Connecting to ' + url
^
SyntaxError: invalid syntax
reloading plugin SublimeWebInspector.websocket
Traceback (most recent call last):
File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 73, in reload_plugin
m = importlib.import_module(modulename)
File "X/importlib/init.py", line 88, in import_module
File "", line 1577, in _gcd_import
File "", line 1558, in _find_and_load
File "", line 1525, in _find_and_load_unlocked
File "C:\Program Files\Sublime Text 3\sublime_plugin.py", line 671, in load_module
exec(compile(source, source_path, 'exec'), mod.dict)
File "websocket in C:\Users\prabhu_a\AppData\Roaming\Sublime Text 3\Installed Packages\SublimeWebInspector.sublime-package", line 717
except Exception, e:
^
SyntaxError: invalid syntax

@Worthy7
Worthy7 commented Mar 28, 2014

It looks like Sublime might be using Py3.0 and the web inspector is written in something older because in py3 print is now print().
But I don't even have Py3 installed so it must have it all built in.

@prabhuanirudhxoriant

So what is the solution for it? I will also check which python version I got

From: Worthy7 [mailto:notifications@github.com]
Sent: Friday, March 28, 2014 2:49 PM
To: sokolovstas/SublimeWebInspector
Cc: Anirudh Prabhu
Subject: Re: [SublimeWebInspector] Is this a python <3 problem? (#62)

It looks like Sublime might be using Py3.0 and the web inspector is written in something older because in py3 print is now print()


Reply to this email directly or view it on GitHubhttps://github.com/sokolovstas/SublimeWebInspector/issues/62#issuecomment-38900424.

@Worthy7
Worthy7 commented Mar 28, 2014

I dunno, its up to the owner to sort it out i guess.

@prabhuanirudhxoriant

Has anyone successfully solved this issue?

@PetaPetaPeta

You probably need to checkout the ST3 branch instead of the master branch.

@sokolovstas
Owner

fixed packages.json

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment