Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 45 lines (33 sloc) 1.184 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44
begin
  # Just in case the bundle was locked
  # This shouldn't happen in a dev environment but lets be safe
  require File.expand_path('../../.bundle/environment', __FILE__)
rescue LoadError
  require 'rubygems'
  require 'bundler'
  Bundler.setup
end

Bundler.require(:default, :development)

begin
  require 'rake'

  gem 'jeweler', '~> 1.5.2'
  require 'jeweler'

  Jeweler::Tasks.new do |gem|

    gem.name = 'dm-taggings'
    gem.summary = 'Tagging plugin for DataMapper'
    gem.description = 'DataMapper plugin providing taggable and tagger models'
    gem.email = 'piotr.solnica@gmail.com'
    gem.homepage = 'http://github.com/solnic/dm-taggings'
    gem.authors = [ 'Piotr Solnica' ]

    gem.add_dependency 'dm-constraints', '~> 1.1.0'
    gem.add_dependency 'dm-is-remixable', '~> 1.1.0'

    gem.add_development_dependency 'rspec', '~> 2.4'
    gem.add_development_dependency 'yard', '~> 0.5'

  end

  Jeweler::GemcutterTasks.new

  FileList['tasks/**/*.rake'].each { |task| import task }

rescue LoadError => e
  puts 'Jeweler (or a dependency) not available. Install it with: gem install jeweler'
  puts e.message
  puts e.backtrace
end
Something went wrong with that request. Please try again.