Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tag: nexus-1.1.1
Fetching contributors…

Cannot retrieve contributors at this time

762 lines (753 sloc) 22.902 kb
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<parent>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-parent</artifactId>
<version>5</version>
</parent>
<artifactId>nexus</artifactId>
<packaging>pom</packaging>
<name>Nexus Repository Manager</name>
<version>1.1.1</version>
<description>Sonatype Nexus Repository Manager</description>
<inceptionYear>2007</inceptionYear>
<mailingLists />
<licenses>
<license>
<name>GNU General Public License</name>
<url>http://www.gnu.org/licenses/gpl.txt</url>
</license>
</licenses>
<developers>
<developer>
<id>cstamas</id>
<name>Tamás Cservenák</name>
<email>cstamas@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>2</timezone>
</developer>
<developer>
<id>brianf</id>
<name>Brian Fox</name>
<email>brian@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>-6</timezone>
</developer>
<developer>
<id>eu</id>
<name>Eugene Kuleshov</name>
<email>eugene@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>-6</timezone>
</developer>
<developer>
<id>jrichard</id>
<name>Justin Richard</name>
<email>justin@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>-6</timezone>
</developer>
<developer>
<id>jvanzyl</id>
<name>Jason van Zyl</name>
<email>jason@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>-9</timezone>
</developer>
<developer>
<id>juven</id>
<name>Juven Xu</name>
<email>juven@sonatype.com</email>
<organization>Sonatype</organization>
<roles>
<role>Developer</role>
</roles>
<timezone>8</timezone>
</developer>
</developers>
<contributors>
<contributor>
<name>John Casey</name>
<email>john@sonatype.com</email>
<organization>Sonatype</organization>
</contributor>
</contributors>
<repositories>
<repository>
<id>sonatype-forge</id>
<url>http://repository.sonatype.org/content/groups/forge</url>
<snapshots>
<enabled>true</enabled>
</snapshots>
<releases>
<enabled>true</enabled>
</releases>
</repository>
</repositories>
<pluginRepositories>
<pluginRepository>
<id>sonatype-forge</id>
<url>http://repository.sonatype.org/content/groups/forge</url>
<snapshots>
<enabled>true</enabled>
</snapshots>
<releases>
<enabled>true</enabled>
</releases>
</pluginRepository>
</pluginRepositories>
<modules>
<module>nexus-utils</module>
<module>nexus-api</module>
<module>nexus-configuration</module>
<module>nexus-proxy</module>
<module>nexus-app</module>
<module>nexus-rest-api</module>
<module>nexus-migration-tool</module>
<module>nexus-webapp</module>
<module>nexus-clients</module>
<module>nexus-repository-conversion-tool</module>
</modules>
<profiles>
<profile>
<id>test-harness</id>
<activation>
<activeByDefault>true</activeByDefault>
<property>
<name>test-harness</name>
</property>
</activation>
<modules>
<module>nexus-test-harness</module>
</modules>
</profile>
</profiles>
<!-- Shortcuts for outnumbered deps :) -->
<properties>
<plexus.appbooter.version>1.6.4</plexus.appbooter.version>
<jsw.binaries.version>3.2.3.2</jsw.binaries.version>
<plexus-jsecurity-realms.version>1.0.1</plexus-jsecurity-realms.version>
<slf4j.version>1.5.3</slf4j.version>
<maven.version>2.1-SONATYPE-653485</maven.version>
<maven.artifact.version>3.0-SONATYPE-653272</maven.artifact.version>
<nexus.indexer.version>1.0.2</nexus.indexer.version>
<!-- Shared with nexus-client, hence it is properties'ed -->
<plexus.restlet.bridge.version>1.5</plexus.restlet.bridge.version>
<micromailer.version>1.0.1</micromailer.version>
</properties>
<dependencyManagement>
<dependencies>
<!-- Platform -->
<dependency>
<groupId>org.sonatype.appbooter.plexus-booters</groupId>
<artifactId>plexus-app-booter</artifactId>
<version>${plexus.appbooter.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.sonatype.appbooter.plexus-booters</groupId>
<artifactId>plexus-jsw-app-booter</artifactId>
<version>${plexus.appbooter.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.sonatype.appbooter.plexus-platforms</groupId>
<artifactId>plexus-platform-jsw</artifactId>
<version>${plexus.appbooter.version}</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.sonatype.jsw-binaries</groupId>
<artifactId>jsw-binaries</artifactId>
<version>${jsw.binaries.version}</version>
<type>zip</type>
<!--make sure this doesn't get into any classpaths-->
<scope>provided</scope>
</dependency>
<!-- Plexus et al -->
<dependency>
<groupId>org.sonatype.plexus</groupId>
<artifactId>plexus-jetty6</artifactId>
<version>1.1</version>
</dependency>
<dependency>
<groupId>org.sonatype.plexus</groupId>
<artifactId>plexus-task-scheduler</artifactId>
<version>1.0</version>
</dependency>
<dependency>
<groupId>org.sonatype.plexus</groupId>
<artifactId>plexus-restlet-bridge</artifactId>
<version>${plexus.restlet.bridge.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-digest</artifactId>
<version>1.1</version>
<exclusions>
<exclusion>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-component-api</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-cli</artifactId>
<version>1.2</version>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-container-default</artifactId>
<scope>provided</scope>
<version>1.0-beta-1</version>
<!-- version>1.0-alpha-47</version-->
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging-api</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-classworlds</artifactId>
<version>1.2-alpha-13</version>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-utils</artifactId>
<version>1.5.5</version>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-interpolation</artifactId>
<version>1.1</version>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-slf4j-logging</artifactId>
<version>1.1-alpha-1</version>
<exclusions>
<exclusion>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-component-api</artifactId>
</exclusion>
<exclusion>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-simple</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-cli</groupId>
<artifactId>commons-cli</artifactId>
<version>1.0</version>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
<version>1.2</version>
</dependency>
<dependency>
<groupId>org.sonatype.micromailer</groupId>
<artifactId>micromailer</artifactId>
<version>${micromailer.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-velocity</artifactId>
<version>1.1.7</version>
<type>jar</type>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-component-api</artifactId>
</exclusion>
<exclusion>
<groupId>velocity</groupId>
<artifactId>velocity</artifactId>
</exclusion>
<exclusion>
<groupId>commons-collections</groupId>
<artifactId>commons-collections</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.apache.velocity</groupId>
<artifactId>velocity</artifactId>
<version>1.5</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<!-- JSecurity -->
<dependency>
<groupId>org.sonatype.jsecurity</groupId>
<artifactId>security-xml-realm</artifactId>
<version>${plexus-jsecurity-realms.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.jsecurity</groupId>
<artifactId>method-realm</artifactId>
<version>${plexus-jsecurity-realms.version}</version>
</dependency>
<dependency>
<groupId>org.jsecurity</groupId>
<artifactId>jsecurity</artifactId>
<version>0.9.0-RC2-SONATYPE</version>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-beanutils</groupId>
<artifactId>commons-beanutils</artifactId>
<version>1.7.0</version>
<scope>runtime</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- SLF4J Logging -->
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>${slf4j.version}</version>
<type>jar</type>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>${slf4j.version}</version>
<type>jar</type>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>jcl-over-slf4j</artifactId>
<version>${slf4j.version}</version>
<type>jar</type>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>jul-to-slf4j</artifactId>
<version>${slf4j.version}</version>
<type>jar</type>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.14</version>
</dependency>
<!-- Maven -->
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-model</artifactId>
<version>${maven.version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-project</artifactId>
<version>${maven.version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-plugin-api</artifactId>
<version>${maven.version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven</groupId>
<artifactId>maven-core</artifactId>
<version>${maven.version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven.artifact</groupId>
<artifactId>maven-artifact</artifactId>
<version>${maven.artifact.version}</version>
</dependency>
<dependency>
<groupId>org.apache.maven.archetype</groupId>
<artifactId>archetype-common</artifactId>
<version>2.0-alpha-1</version>
<exclusions>
<exclusion>
<groupId>org.apache.maven</groupId>
<artifactId>maven-project</artifactId>
</exclusion>
<exclusion>
<groupId>org.apache.maven</groupId>
<artifactId>maven-core</artifactId>
</exclusion>
<exclusion>
<groupId>org.codehaus.plexus</groupId>
<artifactId>plexus-velocity</artifactId>
</exclusion>
<exclusion>
<groupId>velocity</groupId>
<artifactId>velocity</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- Wagon -->
<dependency>
<groupId>org.apache.maven.wagon</groupId>
<artifactId>wagon-provider-api</artifactId>
<version>1.0-beta-2</version>
</dependency>
<dependency>
<groupId>org.apache.maven.wagon</groupId>
<artifactId>wagon-http-lightweight</artifactId>
<version>1.0-beta-2</version>
</dependency>
<!-- Various commonly used deps -->
<dependency>
<groupId>rome</groupId>
<artifactId>rome</artifactId>
<version>0.9</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>com.thoughtworks.xstream</groupId>
<artifactId>xstream</artifactId>
<version>1.3</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>commons-fileupload</groupId>
<artifactId>commons-fileupload</artifactId>
<version>1.2.1</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<!-- Storage impls -->
<dependency>
<groupId>commons-net</groupId>
<artifactId>commons-net</artifactId>
<version>1.4.1</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpclient</artifactId>
<version>4.0-alpha4</version>
<type>jar</type>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>org.apache.httpcomponents</groupId>
<artifactId>httpcore</artifactId>
<version>4.0-beta2</version>
<type>jar</type>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-httpclient</groupId>
<artifactId>commons-httpclient</artifactId>
<version>3.1</version>
<type>jar</type>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-transaction</groupId>
<artifactId>commons-transaction</artifactId>
<version>1.2</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
<version>1.2</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>commons-lang</groupId>
<artifactId>commons-lang</artifactId>
<version>2.3</version>
<type>jar</type>
<scope>runtime</scope>
</dependency>
<dependency>
<groupId>org.apache.lucene</groupId>
<artifactId>lucene-core</artifactId>
<version>2.3.2</version>
<type>jar</type>
<scope>compile</scope>
</dependency>
<dependency>
<groupId>net.sf.ehcache</groupId>
<artifactId>ehcache</artifactId>
<version>1.4.1</version>
<type>jar</type>
<scope>compile</scope>
<exclusions>
<exclusion>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</exclusion>
</exclusions>
</dependency>
<!-- Tests -->
<dependency>
<groupId>org.sonatype.plexus</groupId>
<artifactId>plexus-jetty-testsuite</artifactId>
<version>1.1</version>
<type>jar</type>
<scope>test</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>3.8.2</version>
<type>jar</type>
<scope>test</scope>
</dependency>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>2.4</version>
<type>jar</type>
<scope>test</scope>
</dependency>
<!-- The modules -->
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-utils</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-api</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-configuration</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-indexer</artifactId>
<version>${nexus.indexer.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-proxy</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-app</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-webapp</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.sonatype.nexus</groupId>
<artifactId>nexus-rest-api</artifactId>
<version>${project.version}</version>
</dependency>
</dependencies>
</dependencyManagement>
<!-- build information for the project -->
<build>
<plugins>
<plugin>
<artifactId>maven-enforcer-plugin</artifactId>
<version>1.0-alpha-4</version>
<executions>
<execution>
<goals>
<goal>enforce</goal>
</goals>
<id>enforce</id>
<configuration>
<rules>
<bannedDependencies>
<excludes>
<exclude>velocity:velocity:jar:1.4</exclude>
<exclude>velocity:velocity-dep:jar:1.4</exclude>
</excludes>
<message> Velocity 1.4 is banned, Velocity 1.5 should be used! You probably added a dependency that is missing the
exclusions. </message>
</bannedDependencies>
<bannedDependencies>
<excludes>
<exclude>commons-logging:*</exclude>
</excludes>
<message> commons-logging conflicts with slf4j. You probably added a dependency that is missing the
exclusions. </message>
</bannedDependencies>
<bannedDependencies>
<excludes>
<exclude>*:plexus-component-api</exclude>
</excludes>
<message> plexus-component-api conflicts with newer plexus-container-default. You probably added a dependency that is plexus component made
with older plexus container. </message>
</bannedDependencies>
<!-- <requirePluginVersions>
<banSnapshots>false</banSnapshots>
</requirePluginVersions>-->
</rules>
<fail>true</fail>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
<executions>
<execution>
<id>attach-sources</id>
<phase>verify</phase>
<goals>
<goal>jar</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
<pluginManagement>
<plugins>
<plugin>
<artifactId>maven-assembly-plugin</artifactId>
<version>2.2-beta-2</version>
<dependencies>
<dependency>
<groupId>org.sonatype.spice</groupId>
<artifactId>maven-assembly-helpers</artifactId>
<version>1.0</version>
</dependency>
</dependencies>
</plugin>
<plugin>
<artifactId>maven-eclipse-plugin</artifactId>
<configuration>
<downloadSources>true</downloadSources>
<downloadJavadocs>true</downloadJavadocs>
<wtpversion>1.5</wtpversion>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>retrotranslator-maven-plugin</artifactId>
<version>1.0-alpha-2</version>
</plugin>
<plugin>
<groupId>org.codehaus.modello</groupId>
<artifactId>modello-maven-plugin</artifactId>
<version>1.0-alpha-17</version>
</plugin>
<plugin>
<artifactId>plx-maven-plugin</artifactId>
<groupId>org.sonatype.plugins</groupId>
<version>1.3</version>
</plugin>
<plugin>
<artifactId>maven-resources-plugin</artifactId>
<version>2.3</version>
<dependencies>
<dependency>
<groupId>org.apache.maven.shared</groupId>
<artifactId>maven-filtering</artifactId>
<version>1.0-beta-3-SONATYPE-682132</version>
</dependency>
</dependencies>
</plugin>
</plugins>
</pluginManagement>
</build>
<reporting>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>cobertura-maven-plugin</artifactId>
<version>2.0</version>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>findbugs-maven-plugin</artifactId>
<version>1.1.1</version>
<configuration>
<omitVisitors>UnreadFields</omitVisitors>
</configuration>
</plugin>
<plugin>
<artifactId>maven-jxr-plugin</artifactId>
<version>2.0</version>
</plugin>
<plugin>
<artifactId>maven-pmd-plugin</artifactId>
<version>2.3</version>
<configuration>
<targetJdk>1.5</targetJdk>
</configuration>
</plugin>
</plugins>
</reporting>
<scm>
<connection>scm:svn:http://svn.sonatype.org/nexus/tags/nexus-1.1.1</connection>
<developerConnection>scm:svn:https://svn.sonatype.org/nexus/tags/nexus-1.1.1</developerConnection>
<url>http://svn.sonatype.org/nexus/tags/nexus-1.1.1</url>
</scm>
</project>
Jump to Line
Something went wrong with that request. Please try again.