Permalink
Browse files

ActiveRecord has a 'gem' line in it that conflicts with what Bundler …

…knows for reasons.
  • Loading branch information...
1 parent e51af68 commit 46fb70adb7811882e17aac0389ac54239300fbb0 @jcoglan jcoglan committed Dec 10, 2012
View
@@ -1,23 +1,23 @@
if RUBY_VERSION < '1.9'
appraise 'activerecord_2_2' do
- gem 'activerecord', '~> 2.2.3'
+ gem 'activerecord', '~> 2.2.0'
gem 'factory_girl', '~> 2.3.0'
gem 'rake', '~> 0.8.7'
end
end
appraise 'activerecord_2_3' do
- gem 'activerecord', '~> 2.3.8'
+ gem 'activerecord', '~> 2.3.0'
end
appraise 'activerecord_3_0' do
- gem 'activerecord', '~> 3.0.15'
+ gem 'activerecord', '~> 3.0.0'
end
appraise 'activerecord_3_1' do
- gem 'activerecord', '~> 3.1.6'
+ gem 'activerecord', '~> 3.1.0'
end
appraise 'activerecord_3_2' do
- gem 'activerecord', '~> 3.2.6'
+ gem 'activerecord', '~> 3.2.0'
end
@@ -2,6 +2,6 @@
source :rubygems
-gem "activerecord", "~> 2.3.8"
+gem "activerecord", "~> 2.3.0"
gemspec :path=>"../"
@@ -2,6 +2,6 @@
source :rubygems
-gem "activerecord", "~> 3.0.15"
+gem "activerecord", "~> 3.0.0"
gemspec :path=>"../"
@@ -2,6 +2,6 @@
source :rubygems
-gem "activerecord", "~> 3.1.6"
+gem "activerecord", "~> 3.1.0"
gemspec :path=>"../"
@@ -2,6 +2,6 @@
source :rubygems
-gem "activerecord", "~> 3.2.6"
+gem "activerecord", "~> 3.2.0"
gemspec :path=>"../"
@@ -19,7 +19,7 @@ spec = Gem::Specification.new do |s|
s.add_development_dependency("appraisal", "~> 0.4.0")
s.add_development_dependency("activerecord", "~> 3.2.0") # The SQLite adapter in 3.1 is broken
- s.add_development_dependency("mysql") if ENV["DB"] == "mysql"
+ s.add_development_dependency("mysql", "~> 2.8.0") if ENV["DB"] == "mysql" # version locked by ActiveRecord
s.add_development_dependency("pg") if ENV["DB"] == "postgres"
s.add_development_dependency("rspec")
s.add_development_dependency("sqlite3")

0 comments on commit 46fb70a

Please sign in to comment.