annoying bug in setup.py #16

Closed
davidedelvento opened this Issue Apr 2, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@davidedelvento

When installing scoop with its setup.py it requests argparse>=1.1 in install_require. That downloads and installs arparse 1.2.1 even when using python 2.7 which already has its own argparse 1.1.

This is a serious problem, because argparse 1.2.1 is old and bugous, and after it is installed, it is used instead of the system one, causing hard-to-track-down troubles such as the one described http://stackoverflow.com/questions/29374044/

So, please change the requirements using a conditional append, e.g.

    if sys.version_info < something:
        install_requires. append('argparse>=1.1')

Moreover, you may want to investigate why that requirement pulls argparse 1.2.1 when on PyPI there is 1.2.2 and 1.3 available.

@soravux

This comment has been minimized.

Show comment
Hide comment
@soravux

soravux Aug 21, 2015

Owner

Thanks for the report. Fixed in 39e8bd4.

Owner

soravux commented Aug 21, 2015

Thanks for the report. Fixed in 39e8bd4.

@soravux soravux closed this Aug 21, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment