Skip to content

Audio glitch in downloaded video (hds; svtplay, tv4play) #36

Closed
quite opened this Issue Mar 26, 2013 · 14 comments

4 participants

@quite
quite commented Mar 26, 2013

There is a problem with HDS download from svtplay (and tv4play as well, it seems). The videos I get have an audio glitch every 6 seconds. Typically at 00:05, 00:11, 00:17. Mplayer does play the whole video, but the audio noise/interruption is very noticeable and rather disturbing. VLC player actually stops playing any sound at all after the first occurence of a glitch. In Totem media player I don't hear any glitch.

If I use --hls, and get the .ts file, there is no glitch. At least for the reference video below, I didn't try others. Also, choosing a different quality doesn't seem to matter.

Reference: http://www.svtplay.se/klipp/1121175/brasilienkott0730

My system is an updated Arch Linux, so software is the latest, potentially bleeding.

Can we somehow verify the downloaded flv? Is it a matter of decoder? Codec? AAC is the choice of these sites.

I tried with mplayer -afm ffmpeg and -afm faad. No difference. Actually, with mplayer -novideo, it quits at the first glitch, 00:05, and exits with code 0. With -msglevel all=9, I see:

demux_lavf_fill_buffer()
ds_fill_buffer: EOF reached (stream: audio)  
A:   5.7 (05.6) of 79.9 (01:19.9)  0.6% 
ds_fill_buffer: EOF reached (stream: audio)  
A:   5.7 (05.7) of 79.9 (01:19.9)  0.6% 
EOF code: 1

Well...

@spaam
Owner
spaam commented Mar 26, 2013

interesting. i dont have any issue with this on OSX with vlc or mplayer2. i have tried to mux to file with avconv / ffmpeg to another container and flv. but i dont get any complains about the file.

@durian
durian commented Mar 26, 2013

I noticed too - I downloaded part one of black-mirror (http://www.svtplay.se/video/1102220/del-1-av-3-the-national-anthem) without --hls and got an .flv file with bad audio. Redownloading it with --hls got a normal playing .ts file.

edit; version 0.9.2013.03.06, on debian.

@spaam
Owner
spaam commented Mar 26, 2013

@durian , what media player do you use? debian testing? stable? unstable?

@durian
durian commented Mar 26, 2013

A Roxcore Base media player from Kjell & co :-)

No idea what it contains, and I have to admit I didn't try to play the file with another player as I thought that the --hls was mandatory.

@quite
quite commented Mar 26, 2013

I tried mplayer2, and there is no glitch! What gives hmmm...

@quite
quite commented Mar 26, 2013

Can we make sure we're getting the same data?

svtplay-dl -q348 http://www.svtplay.se/klipp/1121337/magnus-utvik-recenserar-veckans-bocker
md5sum: 5fe22531745cbedc9475fbf84eeaa03b

I guess there must be some extra data where the audio interruption occurs, either some junk or some header, that players/decoders handle differently.

@spaam
Owner
spaam commented Mar 26, 2013

i get the same hash.
MD5 (magnus-utvik-recenserar-veckans-boumlcker-svt-play.flv) = 5fe22531745cbedc9475fbf84eeaa03b

@durian
durian commented Mar 26, 2013

and me too:
5fe22531745cbedc9475fbf84eeaa03b magnus-utvik-recenserar-veckans-boumlcker-svt-play.flv

@quite
quite commented Mar 26, 2013

Hmm well, there is something about the chunks of data that svtplay-dl fetches and writes, I guess. Their length seems to be about 5-6 seconds; judging from the progressbar.

My solution for now is: ffmpeg -i downloaded.flv -codec copy fixed.flv

@spaam
Owner
spaam commented Mar 26, 2013

the thing is that i write a bit to much data. i think the problem is in decode_f4f function..

@quite
quite commented Mar 27, 2013
@quite
quite commented Sep 2, 2013

ping?

@dentarg
Collaborator
dentarg commented Jul 12, 2014

I've noticed this problem too, on OS X with VLC.

Downloaded http://www.tv4play.se/program/fotbolls-vm?video_id=2689218 with svtplay-dl 0.9.2014.04.27.

MD5 (fotbolls-vm-2014-brasilien-tyskland-tv4-play.flv) = ea3ffd174407b3975a252c5a51694f98

Thanks for the workaround @quite.

@quite
quite commented Jul 12, 2014

The fix should actually create an mkv, which is what worked for me:
ffmpeg -i downloaded.flv -codec copy fixed.mkv

@spaam spaam closed this in 4218dd5 Mar 22, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.