Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fails to install branches with / in the branch name #257

Closed
codedmart opened this issue Jun 10, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@codedmart
Copy link
Contributor

commented Jun 10, 2019

We commonly use branch names like kimi/update/table. Spago fails to install branches with / in the branch name. Example output error that I am seeing.

spago: Installation failed.

Error:

.spago/__download-lumi-components-kimi/update/table-c8f2fba29333e838: createDirectory: does not exist (No such file or directory)

codedmart added a commit to codedmart/spago that referenced this issue Jun 10, 2019

codedmart added a commit to codedmart/spago that referenced this issue Jun 10, 2019

@codedmart codedmart referenced this issue Jun 10, 2019

Merged

Replace `/`'s for cache version dir name #258

2 of 3 tasks complete
@f-f

This comment has been minimized.

Copy link
Member

commented Jun 10, 2019

This should be fixed anyways, but I'll note that branches are not really recommended with spago: the reason is that if you push more commits to the branch after you installed it once, spago won't pick up the new changes and you'll have to delete the .spago folder in order to make it pull the new stuff.

You could avoid all of this by just pointing at commit hashes

@f-f f-f added the defect label Jun 10, 2019

codedmart added a commit to codedmart/spago that referenced this issue Jun 10, 2019

codedmart added a commit to codedmart/spago that referenced this issue Jun 10, 2019

@f-f f-f closed this in #258 Jun 18, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.