Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Jun 6, 2010
  1. @vslavik @andymatuschak

    Fix 10.4 compatiblity broken by delta updates.

    vslavik authored andymatuschak committed
    Delta updates code uses libxar, which is only available in 10.5+, and
    Sparkle framework fails to load on 10.4 because of it. Instead of having
    hard dependency on libxar, Sparkle now links with it weakly and checks
    for its availability at runtime.  This required bumping Xcode project
    compatibility to 3.2 to get weak linking support.
    
    With this change, delta updates are still not supported on 10.4, but
    Sparkle runs there again and just ignores the deltas. This should be
    good enough given 10.4's age and shrinking user base.
Something went wrong with that request. Please try again.