Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

The update is improperly signed. #233

Open
grav opened this Issue Dec 6, 2012 · 3 comments

Comments

Projects
None yet
3 participants

grav commented Dec 6, 2012

I've been reading the other threads about this error, but I haven't come close to a solution.

I've checked the file size, generated keys using the script (also tried the one from here: andymatuschak#114 (comment)), made sure the pub-key is in the app, etc. But I still get the above-mentioned error.

Bit of info:

OS X 10.8.2
Sparkle 1.5b6

$ openssl version
OpenSSL 0.9.8r 8 Feb 2011

        <enclosure url="http://localhost:8000/bluemidihost.zip" 
            sparkle:version="2" 
            length="501979" 
            type="application/octet-stream" 
            sparkle:dsaSignature="MCwCFHVMzco0BhPwdSwK4pRTD8xJjoN1AhRk1CjcwSN3t6ECK9QBh8fowEsaIQ==" />

alanshaw commented Sep 1, 2013

Did you ever solve? I'm having the same problem.

no :( still waiting for a reply

alanshaw commented Sep 2, 2013

Things are working. Not entirely sure exactly what step made that become true.

I used the new version of generate_keys.rb, not the one in the 1.5b6 dist.

I pulled from master, built and linked into my app.

I also used a zip file instead of a dmg and made sure there was nothing else in the zip aside from my app.

Hope that helps anyone else.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment