Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Sparkle gives ambiguous error message #258

Closed
SevenBits opened this Issue · 3 comments

2 participants

@SevenBits

I know I have a valid appcast, as older versions of the application still work. I believe the problem started occurring around when I became a registered Mac App Developer and installed my certificate in Xcode, however, turning off code signing does not ameliorate the problem. This is the error message:

2013-03-21 19:07:14.485 Mac Linux USB Loader[2312:303] Sparkle Error: An error occurred in retrieving update information. Please try again later.
2013-03-21 19:07:14.487 Mac Linux USB Loader[2312:303] Sparkle Error (continued): The operation couldn’t be completed. Operation not permitted

Sparkle then just displays a generic NSAlert telling me that it failed. I tried signing the framework but that did not fix the problem.

@KenThomases

Is there something more specific in ~/Library/Logs/SparkleUpdateLog.log?

@SevenBits

I'll check on that.

@SevenBits

I looked through the logs and found my problem. I had forgotten to add network capability for the update checker to the entitlements file. My bad!

@SevenBits SevenBits closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.