Update is not working. Getting "improperly signed" when I signed my app using my developer id #261

Closed
redjersey opened this Issue Mar 26, 2013 · 1 comment

Projects

None yet

1 participant

@redjersey

Hi,

I have sparkle's framework added to my project, however when I tried to update it I got the error message saying "improperly signed".

here's what I did.
in my .xml I have:

how I got the length is by using ls -la and copy and paste the byte number to the length attribute.

How I created My App.zip:

I archived my project, select "Export Developer ID-signed Application", picked my developer id from the drop down list, saved My App.app to my desktop. I then zip the My App.asp as My App.zip then uploaded the zip file to mydomain.

download progress works, however after finished downloading, I got the popup saying "improperly signed".

I'm pretty sure the code signing process works, otherwise I won't be able to run my app (due to gatekeeper feature in ML) so I really have no clue why it doesn't work.

btw I'm using sparkle 1.5 b6

@redjersey

nevermind, found this:
#227

turns out the one that I downloaded from the website 1.5 b6 doesn't work when using the developer id. I had to download from git and grab the framework from it, now it's fine :)

@redjersey redjersey closed this Mar 27, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment