can't install and launch, got the extract error #275

Closed
redjersey opened this Issue May 28, 2013 · 7 comments

Comments

Projects
None yet
7 participants

I'm having some problem with sparkle.

When I select "Check for updates..." it downloaded the zip file properly, however once I pressed the "Install and launch" I got the error message saying:

An error occurred while extracting the archive. Please try again later

I looked at my console and I got the following error:

2013-05-28 3:07:34.942 PM mdworker[2828]: zip importer encountered an error (2) scanning "/Users/myusername/Library/Application Support/MyApp/MyApp 1.2/MyApp-v1.1.zip".

I used the default mac program to zip the file.

That error is not directly related to Sparkle. It's from Spotlight as it tries to import information about the Zip archive. Still, it might indicate a real problem with the archive.

What happens when you try to open that Zip archive directly by, for example, double-clicking it in the Finder?

I am having this exact same problem with my app. I can watch it download the zip file, extract the pkg file from it, (I can double click the archive in the finder OR run the pkg without errors from Finder, but the second I click Install and Relaunch, I get the same error as redjersey. Is there a way to properly debug sparkle? There's no console messages at all, and no real way to step through it that I've found.

When you say there are no console messages, are you including ~/Library/Logs/SparkleUpdateLog.log?

Yeah I found that after I sent that (I was at the height of frustration
yesterday)... but when it checks, it doesn't log the version you think you
have nor the version it thinks is on the server, which I think would be
rather handy for figuring out where a problem is (as opposed to having to
add a bunch of extra logging to the host app). I might have to see about
adding that.

On Thu, Jun 20, 2013 at 3:05 PM, KenThomases notifications@github.comwrote:

When you say there are no console messages, are you including
~/Library/Logs/SparkleUpdateLog.log?


Reply to this email directly or view it on GitHubhttps://github.com/andymatuschak/Sparkle/issues/275#issuecomment-19779518
.

Allen

Did someone got any update on this? I am facing the same problem. The dmg extracts fine if I try it myself. But, if I try doing with Sparkle then it shows this error "Update Error! An error occurred while extracting the archive. Please try again later."

liaogang commented Jan 5, 2016

A had the some problem just minutes ago.
But I solved the problem with this step:

  • clean all old files
  • compression the app to a zip file and sign it again

chess92 commented Dec 7, 2016

@liaogang what do you mean by clean the old files?

@pornel pornel closed this Dec 28, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment