Permalink
Browse files

Merge pull request #487 from olleolleolle/patch-1

Travis: Rubies updated, add 2.4.0, fix 2.0.0, 1.9.3; update to jruby-9.1.7.0, add JRUBY_OPTS=--debug
  • Loading branch information...
2 parents c80200c + 171b66a commit 99b3b78d885eb05d49904aa4f210b45b606dbbd8 @knu knu committed on GitHub Feb 8, 2017
Showing with 23 additions and 14 deletions.
  1. +19 −13 .travis.yml
  2. +3 −0 Gemfile
  3. +1 −1 README.rdoc
View
@@ -5,25 +5,31 @@ notifications:
- drbrain@segment7.net
- ljjarvis@gmail.com
- knu@idaemons.org
+
sudo: false
+
# bundler is missing for jruby-head in travis-ci
# https://github.com/travis-ci/travis-ci/issues/5861
-before_install: gem install --conservative bundler
-rvm:
-- 1.9.3
-- 2.0.0
-- 2.1
-- 2.2
-- 2.3.1
-- ruby-head
-- jruby-1.7.26
-- jruby-9.1.5.0
-- jruby-head
+before_install:
+ - gem install --conservative bundler -v'1.13.7'
+
script: rake test
+
matrix:
- allow_failures:
+ include:
- rvm: 1.9.3
- rvm: 2.0.0
+ - rvm: 2.1
+ - rvm: 2.2
+ - rvm: 2.3.3
+ - rvm: 2.4.0
- rvm: ruby-head
- - rvm: jruby-9.1.5.0
+ - rvm: jruby-1.7.26
+ env: JRUBY_OPTS=--debug
+ - rvm: jruby-9.1.7.0
+ env: JRUBY_OPTS=--debug
+ - rvm: jruby-head
+ env: JRUBY_OPTS=--debug
+ allow_failures:
+ - rvm: jruby-9.1.7.0
- rvm: jruby-head
View
@@ -1,3 +1,6 @@
source 'https://rubygems.org'
+# In order to be able to install on 1.9.3 and 2.0.0
+ruby RUBY_VERSION
+
gemspec
View
@@ -1,4 +1,4 @@
-= Mechanize {<img src="https://secure.travis-ci.org/sparklemotion/mechanize.svg?rvm=2.3.1" />}[http://travis-ci.org/sparklemotion/mechanize]
+= Mechanize {<img src="https://secure.travis-ci.org/sparklemotion/mechanize.svg?rvm=2.3.3" />}[http://travis-ci.org/sparklemotion/mechanize]
* http://docs.seattlerb.org/mechanize
* https://github.com/sparklemotion/mechanize

0 comments on commit 99b3b78

Please sign in to comment.