Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

deprecate Ruby 2.2 support #1841

Closed
flavorjones opened this issue Dec 14, 2018 · 1 comment
Closed

deprecate Ruby 2.2 support #1841

flavorjones opened this issue Dec 14, 2018 · 1 comment
Milestone

Comments

@flavorjones
Copy link
Member

@flavorjones flavorjones commented Dec 14, 2018

Ruby 2.2 reached EOL in June 2018.

https://www.ruby-lang.org/en/news/2018/06/20/support-of-ruby-2-2-has-ended/

Potential actions:

  • remove it from the Windows gem in an upcoming release.
  • update the gemspec to declare this as no longer compatible
  • update the README
@flavorjones flavorjones changed the title depcreate Ruby 2.2 support deprecate Ruby 2.2 support Dec 14, 2018
@flavorjones flavorjones mentioned this issue Dec 14, 2018
2 of 2 tasks complete
@flavorjones flavorjones added this to the v1.10.0 milestone Dec 14, 2018
@flavorjones
Copy link
Member Author

@flavorjones flavorjones commented Dec 20, 2018

OK, making a punchlist:

  • remove from .cross_rubies so it's not included in Windows gems anymore
  • update the gem spec in Rakefile so min Ruby version is 2.3 (is currently 2.1, which is not right, see #1648 for confusion)
  • update the README to reflect min version
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant