Skip to content
Permalink
Browse files

freeze python irc module at 14.0 in setup.py and add notes about irc …

…version in HOWTO
  • Loading branch information...
Eagle[TM]
Eagle[TM] committed May 8, 2016
1 parent 8bbce1b commit cc97c328469fbdc65b3034fea20f50d3ba8396df
Showing with 6 additions and 1 deletion.
  1. +5 −0 HOWTO.md
  2. +1 −1 setup.py
@@ -151,6 +151,7 @@ We will download the latest git snapshot for Electrum to configure and install i
$ cd ~
$ git clone https://github.com/spesmilo/electrum-server.git
$ cd electrum-server
$ sudo apt-get install python-setuptools
$ sudo configure
$ sudo python setup.py install

@@ -165,6 +166,10 @@ package manager if you don't want to use the install routine.
$ sudo apt-get install python-setuptools python-openssl python-leveldb libleveldb-dev
$ sudo easy_install jsonrpclib irc plyvel

For the python irc module please note electrum-server currently only supports versions between 11 and 14.0.
The setup.py takes care of installing a supported version but be aware of it when installing or upgrading
manually.

Regarding leveldb, see the steps in README.leveldb for further details, especially if your system
doesn't have the python-leveldb package or if plyvel installation fails.

@@ -4,7 +4,7 @@
name="electrum-server",
version="1.0",
scripts=['run_electrum_server.py','electrum-server'],
install_requires=['plyvel','jsonrpclib', 'irc>=11'],
install_requires=['plyvel','jsonrpclib', 'irc >= 11, <=14.0'],
package_dir={
'electrumserver':'src'
},

0 comments on commit cc97c32

Please sign in to comment.
You can’t perform that action at this time.