XP errors opening py file #249

Closed
mrainess opened this Issue Dec 7, 2012 · 2 comments

2 participants

@mrainess

I did a fresh install; removing all dot and underscore vim and spf13 configuration files before starting. Using vim V 7.3.46. There were no errors during the install.

When I open a python file--using either vim or gvim--I get the following errors:

Error detected while processing function pymode#Option:
line 8:
E121: Undefined variable: g:pymode_syntax
E121: Undefined variable: g:pymode_options
E121: Undefined variable: g:pymode_doc
E121: Undefined variable: g:pymode_lint
E121: Undefined variable: g:pymode_rope
E121: Undefined variable: g:pymode_run
E121: Undefined variable: g:pymode_breakpoint
E121: Undefined variable: g:pymode_folding
Error detected while processing C:\Documents and Settings\Mark.vim\bundle\python-mode\after\ftplugin\python.vim:
line 2:
E121: Undefined variable: g:pymode_rope
E15: Invalid expression: g:pymode && g:pymode_rope && g:pymode_rope_vim_completion
Error detected while processing C:\Documents and Settings\Mark.vim\bundle\python-mode\after\indent\python.vim:
line 1:
E121: Undefined variable: g:pymode_indent
E15: Invalid expression: pymode#Default('b:pymode_indent', 1) || !g:pymode_indent
Error detected while processing function pymode#Option:
line 8:
E121: Undefined variable: g:pymode_syntax

@jrobeson
Collaborator

@mrainess can you still reproduce this on a newer spf13-vim ?

@jrobeson jrobeson added the needinfo label Jul 1, 2014
@jrobeson jrobeson removed the needinfo label Jul 11, 2014
@jrobeson
Collaborator

closing for lack of information

@jrobeson jrobeson closed this Jul 11, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment