Skip to content

v1.12.0

Compare
Choose a tag to compare
@sagikazarmark sagikazarmark released this 26 May 15:52
· 35 commits to master since this release
v1.12.0

This release makes YAML v3 and TOML v2 the default versions used for encoding.

You can switch back to the old versions by adding viper_yaml2 and viper_toml1 to the build tags.

Please note that YAML v2 and TOML v1 are considered deprecated from this release and may be removed in a future release.

Please provide feedback in discussions and report bugs on the issue tracker. Thanks!

What's Changed

Exciting New Features 🎉

Enhancements 🚀

  • chore: fix Error log calls in mergeMaps by @wwade in #1341
  • Add MustBindEnv by @meowfaceman in #1301

Dependency Updates ⬆️

  • build(deps): bump github/codeql-action from 1 to 2 by @dependabot in #1336
  • build(deps): bump github.com/pelletier/go-toml/v2 from 2.0.0-beta.8 to 2.0.0 by @dependabot in #1339
  • build(deps): bump github.com/mitchellh/mapstructure from 1.4.3 to 1.5.0 by @dependabot in #1332
  • build(deps): bump github.com/pelletier/go-toml from 1.9.4 to 1.9.5 by @dependabot in #1335
  • build(deps): bump github.com/fsnotify/fsnotify from 1.5.1 to 1.5.4 by @dependabot in #1338
  • build(deps): bump github.com/spf13/cast from 1.4.1 to 1.5.0 by @dependabot in #1344
  • build(deps): bump github.com/pelletier/go-toml/v2 from 2.0.0 to 2.0.1 by @dependabot in #1343
  • build(deps): bump github.com/subosito/gotenv from 1.2.0 to 1.3.0 by @dependabot in #1349

New Contributors

  • @meowfaceman made their first contribution in #1301
  • @wwade made their first contribution in #1341

Full Changelog: v1.11.0...v1.12.0