Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Quick-start utility questions missing #6346

Closed
matthijsramlab opened this issue May 8, 2019 · 2 comments
Labels

Comments

@matthijsramlab
Copy link

@matthijsramlab matthijsramlab commented May 8, 2019

Describe the bug

When I am using the quick-start command, some of the questions are not asked. I get the following questions:

Welcome to the Sphinx 2.0.1 quickstart utility.

Please enter values for the following settings (just press Enter to
accept a default value, if one is given in brackets).

Selected root path: .

You have two options for placing the build directory for Sphinx output.
Either, you use a directory "_build" within the root path, or you separate
"source" and "build" directories within the root path.

Separate source and build directories (y/n) [n]: y

The project name will occur in several places in the built documentation.

Project name: MonitoringApp
Author name(s): Test
Project release []: 0.1

If the documents are to be written in a language other than English,
you can select a language here by its language code. Sphinx will then
translate text that it generates into that language.

For a list of supported codes, see
http://sphinx-doc.org/config.html#confval-language.

Project language [en]: en

Creating file .\source\conf.py.
Creating file .\source\index.rst.
Creating file .\Makefile.
Creating file .\make.bat.

Finished: An initial directory structure has been created.

You should now populate your master file .\source\index.rst and create other documentation
source files. Use the Makefile to build the docs, like so:
make builder
where "builder" is one of the supported builders, e.g. html, latex or linkcheck.

I was following the documentation and it seems that are questions missing, in the docs it is asking to say yes to autodoc? Of course, I can edit this to the config.py manually,

@matthijsramlab matthijsramlab added the bug label May 8, 2019
@matthijsramlab matthijsramlab changed the title Quickstart utility questions missn Quick-start utility questions missing May 9, 2019
@tk0miya tk0miya added question and removed bug labels May 13, 2019
@tk0miya

This comment has been minimized.

Copy link
Member

@tk0miya tk0miya commented May 13, 2019

Since 2.0, questions of quickstart become simple (refs: #4148). To enable autodoc, please give --ext-autodoc option to quickstart.

Thanks,

@tk0miya

This comment has been minimized.

Copy link
Member

@tk0miya tk0miya commented May 28, 2019

Closing. Thanks,

@tk0miya tk0miya closed this May 28, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.