Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem with special chars not on first page #486

Open
poitierjohan opened this issue Jun 25, 2019 · 4 comments

Comments

Projects
None yet
2 participants
@poitierjohan
Copy link

commented Jun 25, 2019

Hi all,

I generate a PDF file with this bundle. All works worrectly but not for the specials chars (like é è à, ... - french content) BUT not on the first page !

I compil a pdf from different code like :
$this->pdf->writeHTML($myFirstHtml);
$this->pdf->writeHTML($mySecondHtml);
$this->pdf->writeHTML($myThirdHtml);

No problem on my first page ($myFirstHtml).
But on the second and thirs, all my special chars (é è à, ...) are replace by "??"

If I generate 3 pdf separatly, no problem !

Encoding : UTF-8 (DB and HTML)

How can I resolved this problem ?

Thank you for yours answers...

@LittleBigFox

This comment has been minimized.

Copy link
Contributor

commented Jun 26, 2019

Hi!

$html2pdf = new Html2Pdf('P', 'A4', 'fr', true, 'UTF-8');

The fifth arg of the constructor is the encoding, have a try?

Regards,
LBF

@poitierjohan

This comment has been minimized.

Copy link
Author

commented Jun 26, 2019

@LittleBigFox

This comment has been minimized.

Copy link
Contributor

commented Jun 26, 2019

I'm french too and i don't have this kind of problems...

Can you send the full pdf generation, without html content? On github or by mail?

@poitierjohan

This comment has been minimized.

Copy link
Author

commented Jun 26, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.