New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spock modules should depend on the minimum amount of Groovy 2.5 #899

Open
lptr opened this Issue Sep 10, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@lptr

lptr commented Sep 10, 2018

Issue description

Depending on spock-core-1.2-RC2-groovy-2.5 brings in unwanted dependencies like groovy-sql and jline etc. Instead, each Spock module should depend on the minimum required modules from Groovy.

Thus the behavior of the Groovy 2.5 variant is different from the Groovy 2.4 variant, where types from third-party dependencies aren't present directly, but are remapped inside the groovy-all.jar.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment