Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Converted README from rst to markdown.

Added a compatiblity warning for projects using REST Framework 0.3.X or
0.4.X.
  • Loading branch information...
commit 67bd86af62dc5060fa70e0307e6113fdb9a751f8 1 parent 841d55f
@markotibold markotibold authored
Showing with 22 additions and 33 deletions.
  1. +22 −33 README.rst → README.md
View
55 README.rst → README.md
@@ -1,9 +1,16 @@
-.. image:: https://secure.travis-ci.org/ridethepony/django-fiber.png
- :target: http://travis-ci.org/#!/ridethepony/django-fiber
+[![Travis build image][travis-build-image]][travis]
-============
-Django Fiber
-============
+[travis]: http://travis-ci.org/#!/ridethepony/django-fiber
+[travis-build-image]: https://secure.travis-ci.org/ridethepony/django-fiber.png
+
+#Django Fiber
+
+---
+
+**Announcement**: We've upgraded to Django REST Framework 2. This means that if you want to use the latest
+Fiber and you use Django REST Framework 0.3.X or 0.4.X for your own project, you'll have to bite the bullet and upgrade your local REST Framework code.
+
+---
Do you want to see a Django Fiber screencast, to get a feel for what it can do for you? Check it out here:
http://vimeo.com/ridethepony/django-fiber
@@ -14,36 +21,26 @@ https://github.com/ridethepony/django-fiber-example
Convinced? Want to use Django Fiber in your own Django project? Then follow the instructions below:
-Installation:
-=============
+##Installation
We're assuming you are using Django 1.3.x or 1.4.
-::
-
$ pip install django-fiber
-Requirements:
-=============
+##Requirements
These dependencies are automatically installed:
-::
-
Pillow==1.7.7
djangorestframework==0.3.3
django-mptt==0.5.1
django-compressor>=0.7.1
-Settings:
-=========
-
-settings.py
------------
+##Settings
-::
+###settings.py
import django.conf.global_settings as DEFAULT_SETTINGS
@@ -59,11 +56,9 @@ settings.py
INSTALLED_APPS = (
...
'django.contrib.staticfiles',
- 'djangorestframework',
'mptt',
'compressor',
'fiber',
- ...
)
import os
@@ -75,10 +70,7 @@ settings.py
'compressor.finders.CompressorFinder',
)
-urls.py
--------
-
-::
+###urls.py
from django.conf import settings
@@ -92,19 +84,16 @@ urls.py
)
-Post-installation:
-==================
+##Post-installation
-Create database tables::
+Create database tables:
$ python manage.py syncdb
-All static Fiber files need to be symlinked in (or copied to) your media folder::
+All static Fiber files need to be symlinked in (or copied to) your media folder:
$ python manage.py collectstatic --link
-Further documentation:
-======================
-
-You can find usage instructions, and other documentation, in the docs folder.
+##Further documentation
+For further usage and configuration details take a look at our documentation project at [readthedocs](https://django-fiber.readthedocs.org/en/latest/index.html).
Please sign in to comment.
Something went wrong with that request. Please try again.