Permalink
Browse files

Upgraded gem dependencies, Removed require 'test-unit'

  • Loading branch information...
1 parent 5ec7a1d commit 1dfbc86eaaa424a80467b2fcb3c0ea425d182089 @aslakhellesoy aslakhellesoy committed Oct 11, 2009
Showing with 5 additions and 11 deletions.
  1. +1 −0 History.txt
  2. +0 −1 bin/spork
  3. +0 −6 features/cucumber_rails_integration.feature
  4. +4 −4 geminstaller.yml
View
@@ -1,3 +1,4 @@
+* removed unneeded require 'test-unit'
* prevent more connection errors from destroying the debug client listener loop
* fix lock on second encounter of 'debugger' statement
* prevent situation where debugger stops functioning if connection is dropped by ctrl-c or other forceful means.
View
@@ -1,6 +1,5 @@
#!/usr/bin/env ruby
require 'rubygems'
-gem 'test-unit', '1.2.3' if RUBY_VERSION.to_f >= 1.9 # Why do we need this?
$LOAD_PATH.unshift(File.dirname(__FILE__) + '/../lib') unless $LOAD_PATH.include?(File.dirname(__FILE__) + '/../lib')
@@ -38,12 +38,6 @@ Feature: Cucumber integration with rails
end
Spork.each_run do
- # This code will be run each time you run your specs.
-
- Cucumber::Rails.use_transactional_fixtures
- Cucumber::Rails.bypass_rescue # Comment out this line if you want Rails own error handling
- # (e.g. rescue_action_in_public / rescue_responses / rescue_from)
-
#### this is for this test only #######
$loaded_stuff << 'each_run block' #####
#######################################
View
@@ -1,9 +1,9 @@
defaults:
install_options: "--no-ri --no-rdoc"
gems:
-- { name: 'ruby-sqlite3', version: '>= 1.2.5' }
-- { name: 'cucumber', version: '>= 0.3.101' }
-- { name: 'rspec', version: '>= 1.2.8' }
-- { name: 'rspec-rails', version: '>= 1.2.7.1' }
+- { name: 'sqlite3-ruby', version: '>= 1.2.5' }
+- { name: 'cucumber', version: '>= 0.4.0' }
+- { name: 'rspec', version: '>= 1.2.9' }
+- { name: 'rspec-rails', version: '>= 1.2.9' }
- { name: 'rails', version: '>= 2.3' }

0 comments on commit 1dfbc86

Please sign in to comment.