Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Create Spork::VERSION #142

Closed
wants to merge 2 commits into from

4 participants

@SixArm

Hi Tim,

Here's a solution for Spork to know its own version number. Could you pull this?

This follows the version example from Carl Lerche and Yehuda Katz in the bundler gem:

  • New file /lib/spork/version.rb that defines Spork::VERSION

  • Update to spork.gemspec to require the version.rb for Spork::VERSION

Note that I bumped the version to rc10 to show how it works-- you may want to alter this. The gem builds fine on my setup.

My contact info is joelparkerhenderson on Gmail and Google Talk if you'd like to ask about it.

Thanks,
Joel

@d11wtq

Joel, I think maybe you forgot to commit the version.rb file? The diff is only showing a change in the gemspec.

@parndt

@SixArm is there a lib/spork/version.rb missing from the pull request?

@SixArm

Yes - pushing it now. Thanks for the heads up.

@SixArm

@Tim be sure to update the version # for the current spork.

@sahilm
Owner

Closing old pull requests. Please send new ones if this is still an issue.

@sahilm sahilm closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Sep 19, 2011
  1. @SixArm

    Create Spork::VERSION string

    SixArm authored
Commits on Nov 8, 2011
  1. @SixArm

    Add version file

    SixArm authored
This page is out of date. Refresh to see the latest.
Showing with 9 additions and 1 deletion.
  1. +3 −0  lib/spork/version.rb
  2. +6 −1 spork.gemspec
View
3  lib/spork/version.rb
@@ -0,0 +1,3 @@
+module Spork
+ VERSION = "0.9.0.rc10" unless defined?(::Spork::VERSION)
+end
View
7 spork.gemspec
@@ -1,7 +1,12 @@
+lib = File.expand_path('../lib/', __FILE__)
+$:.unshift lib unless $:.include?(lib)
+
require 'date'
+require 'spork/version'
+
Gem::Specification.new do |s|
s.name = %q{spork}
- s.version = "0.9.0.rc9"
+ s.version = Spork::VERSION
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Tim Harper", "Donald Parish"]
Something went wrong with that request. Please try again.