Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Spotify Web Api playback for smartphone devices does not work when spotify app is backgrounded #1171

Open
liamtrampota opened this Issue Feb 21, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@liamtrampota
Copy link

commented Feb 21, 2019

Issue found on February 19th 2015.

Endpoint(s):

PUT https://api.spotify.com/v1/me/player/play
GET https://api.spotify.com/v1/me/player/devices

Scope(s):

user-modify-playback-state
user-read-playback-state

Steps to reproduce:

  1. Open Spotify App on your smartphone
  2. Minimize (Background) Spotify App
  3. Get smartphone's Spotify device_id (GET https://api.spotify.com/v1/me/player/devices)
  4. Play a song using PUT https://api.spotify.com/v1/me/player/play with your smartphone's device_id from step 3

Expected behaviour:

Playback should resume from Spotify App

Actual behaviour:

Playback does not resume until Spotify is re-opened

@timothy3001

This comment has been minimized.

Copy link

commented Mar 13, 2019

We have got a similar issue: When the smartphone is locked, not used in a certain period of time and the playback queue in spotify finishes then the connection between the Spotify platform and the device is lost.

The device somehow goes offline immediately after finishing the last song in the queue and is not accessible anymore via Spotify Web Api until you restart the Spotify App on the smartphone.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.